Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#371 closed bug (invalid)

In MenuItem, the bgolor of MarkSymbol and SubmenuSymbol.

Reported by: bxi07354@… Owned by: bpmagic@…
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

MenuItem.cpp

BMenuItem::Draw()

+ BMenu *root = fSuper; + if (Menu()->Supermenu()) root = Menu()->Supermenu();

  • rgb_color noTint = ui_color(B_MENU_BACKGROUND_COLOR);

+ rgb_color noTint = root->ViewColor();

BMenuItem::DrawMarkSymbol(rgb_color bgColor)

BRect r(fBounds);

  • r.right = r.left + r.Height();

+ r.right = r.left + Menu()->fPad.left;

r.top += 2; r.bottom -= 2; r.left += 1; r.right -= 5;

+ fSuper->SetLowColor(bgColor); + fSuper->FillRect(r,B_SOLID_LOW);

BMenuItem::DrawSubmenuSymbol(rgb_color bgColor)

+ fSuper->SetLowColor(bgColor); + fSuper->FillRect(r,B_SOLID_LOW);

Attachments (1)

menuitem.a.png (42.5 KB ) - added by bxi07354@… 14 years ago.
After it changes

Download all attachments as: .zip

Change History (5)

by bxi07354@…, 14 years ago

Attachment: menuitem.a.png added

After it changes

comment:1 by johndrinkwater, 14 years ago

Summary: In MenuItem, the bgolor of MarkSymbol and SubmenuSymbol. In MenuItem, the bgolor of MarkSymbol and SubmenuSymbol.

comment:2 by johndrinkwater, 14 years ago

afaik, this is a design change, not a bug

comment:3 by bxi07354@…, 14 years ago

Resolution: invalid
Status: newclosed

comment:4 by bxi07354@…, 14 years ago

(In reply to comment #2)

not a bug

Sorry. Because it is not a bug, it withdraws.

However, it is not a design of R5. Where is the design reported?

Note: See TracTickets for help on using tickets.