Opened 10 years ago

Closed 10 years ago

#3720 closed bug (fixed)

E-Mail preferences crashes when trying to setup POP3 account

Reported by: rossi Owned by: bga
Priority: normal Milestone: R1
Component: Preferences/Mail Version: R1/pre-alpha1
Keywords: Cc: czeidler@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

E-Mail preferences crashes when trying to setup POP3 account as sonn as the OK button is clicked. Here is some GDB output:

GNU gdb 6.3
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i586-pc-haiku"...(no debugging symbols found)

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
Thread 406 caused an exception: Segment violation
Reading symbols from /boot/system/runtime_loader...done.
Loaded symbols for /boot/system/runtime_loader
Reading symbols from /boot/system/lib/libbe.so...done.
Loaded symbols for /boot/system/lib/libbe.so
Reading symbols from /boot/system/lib/libmail.so...done.
Loaded symbols for /boot/system/lib/libmail.so
Reading symbols from /boot/system/lib/libnetwork.so...done.
Loaded symbols for /boot/system/lib/libnetwork.so
Reading symbols from /boot/system/lib/libbnetapi.so...done.
Loaded symbols for /boot/system/lib/libbnetapi.so
Reading symbols from /boot/common/lib/libcrypto.so.0.9.8...done.
Loaded symbols for /boot/common/lib/libcrypto.so.0.9.8
Reading symbols from /boot/common/lib/libssl.so.0.9.8...done.
Loaded symbols for /boot/common/lib/libssl.so.0.9.8
Reading symbols from /boot/system/lib/libroot.so...done.
Loaded symbols for /boot/system/lib/libroot.so
Reading symbols from /boot/system/lib/libstdc++.r4.so...done.
Loaded symbols for /boot/system/lib/libstdc++.r4.so
Reading symbols from /boot/system/lib/libtextencoding.so...done.
Loaded symbols for /boot/system/lib/libtextencoding.so
Reading symbols from /boot/system/lib/libtracker.so...done.
Loaded symbols for /boot/system/lib/libtracker.so
Reading symbols from /boot/system/lib/libiconv.so...done.
Loaded symbols for /boot/system/lib/libiconv.so
Reading symbols from /boot/system/lib/libtranslation.so...done.
Loaded symbols for /boot/system/lib/libtranslation.so
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/system/preferences/E-mail (400) thread w>Create New Account (406)]
0x0021601a in ServerSettingsView::ServerSettingsView ()
(gdb) bt
#0  0x0021601a in ServerSettingsView::ServerSettingsView ()
#1  0x00213932 in AutoConfigWindow::MessageReceived ()
#2  0x002df00b in BLooper::DispatchMessage () from /boot/system/lib/libbe.so
#3  0x00399c0d in BWindow::DispatchMessage () from /boot/system/lib/libbe.so
#4  0x0039d4ec in BWindow::task_looper () from /boot/system/lib/libbe.so
#5  0x002e0567 in BLooper::_task0_ () from /boot/system/lib/libbe.so
#6  0x006b5cd8 in thread_entry () from /boot/system/lib/libroot.so
#7  0x70080fec in ?? ()
(gdb) 

Let me know if more detail is required.

Change History (13)

comment:1 Changed 10 years ago by bga

This was introduced with the recent auto config stuff. I won' t be able to look into it until I get my computer at home connected to the internet again but you could talk to the guy that submitted this patch.

comment:2 Changed 10 years ago by zeidler

Cc: czeidler@… added

Can't reproduce it here. Please give a detailed discription how to reproduce it.

  • which domain / email address
  • ssl?
  • settings

comment:3 Changed 10 years ago by rossi

@Clemens: for obvious reasons, I cannot provide you with the details requested, as I'm of course not posting my login credentials and server details to the public.

But basically its a standard mail server, provided by pair.com where all my domains are hosted.

Basically I just entered my email address, and the other requested info on the POP3 settings dialog and it crashes as soon as I click OK. Some fields are filled automatically, once I entered the address.

No SSL or such enabled.

comment:4 Changed 10 years ago by zeidler

could you add

SetConfigVar DEBUG : HAIKU_TOP src preferences mail : 1 : global ;

to your UserBuildConfig, recompile and send me the trace back? I still can't reproduce it. Which system you are using? linux vm or haiku gcc2 hardware?

comment:5 Changed 10 years ago by rossi

Yes, will do so ... however it will take quite a while, as my build machine is pretty old and slow ;-( a full build takes app. 2h ...

I use hybrid gcc2/gcc4 build on real hardware (Lifebook Q 2010).

Did you try to reproduce with account settings not included in the provider data?

comment:6 Changed 10 years ago by rossi

Opps ... I did enable the debugging stuff and tested again, however with the requested debugging options, the preflet works just fine. Maybe there is something in the debugging code, which is not executed in release builds?

comment:7 Changed 10 years ago by zeidler

I had tried various providers and everythink was working fine (on vm-ware and on real hardware) so I assume for some reason you had a corrupt executable. Please recompile it without debug symbols and try it again. You can use: jam -q update-image E-mail to only update the E-mail app this would be a little bit faster. The DEBUG option is a compiler flag so it should not change the behaviour of the app.

comment:8 Changed 10 years ago by bga

This is not completely true. Debug builds can trigger specific code/checks in the executable so saying it won't change the resulting binary because it is a compile time flag is incorrect.

comment:9 Changed 10 years ago by rossi

Well, as bga pointed out, debug builds can and do indeed behave differently quite some times. Tested as requested again on 30148 and as expected it crashes very reproduceable. Will try again with the latest revision, once the build is done to see whether your commit from today fixes the issue.

comment:10 Changed 10 years ago by rossi

Tested again with hrev30162: ;-) works now, apperently commit 30153 fixed the issue. Ticket can be closed.

comment:11 Changed 10 years ago by zeidler

Do you make sure you really recompile the app without debug symbols and not use the old objects from the previous run? The issues I fixed shouldn't happened in normal usage and should also crash in debug mode. But anyway fine it is working now :-)

comment:12 Changed 10 years ago by rossi

Yes of course I did double check, that the binary was properly rebuild both times. I may have forgotten some things about BeOS since my time at Be but not how to compile an application ;-)

I would still believe that there is some difference between the release and debug build however, otherwise the different behaviour could not be explained. Should be checked sometimes or the next time someone sees crashes using this preflet. Anyhow for now my verdict stays, from my point of view the ticket can be closed.

comment:13 Changed 10 years ago by bga

Resolution: fixed
Status: newclosed

This seems to be fixed now, so I am closing it.

Note: See TracTickets for help on using tickets.