Opened 9 years ago

Closed 2 months ago

#3727 closed bug (fixed)

System gurus under heavy load

Reported by: haiqu Owned by: nobody
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

During a large copy between drives - copying the whole source tree to a flash stick - the system periodically gurus for periods of 30 seconds, during which time the gui interface is non-responsive. Hard disk activity stops, CPU activity is low and there appears to be nothing happening. I have turned off the virtual memory, which was causing disk thrashing and making the system CPU-bound, so this isn't the cause.

Gigabyte 7IXE4 with Duron 800, 640Mb memory.

Snapshot attached.

Attachments (2)

screenshot2 (44.2 KB) - added by haiqu 9 years ago.
Haiku in guru mode
guru.png (44.2 KB) - added by haiqu 9 years ago.
Oops, let's try that again …

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by haiqu

Attachment: screenshot2 added

Haiku in guru mode

Changed 9 years ago by haiqu

Attachment: guru.png added

Oops, let's try that again ...

comment:1 Changed 9 years ago by haiqu

Only just noticed that when this happens the seconds on the clock actually stop counting. There was a jump from .23 to .59 that showed the clock was still running but Tracker wasn't being updated. Maybe this can help locate the bug.

comment:2 Changed 3 years ago by waddlesplash

Still an issue?

comment:3 Changed 3 years ago by haiqu

That computer is in storage 1800km from here so I can't test it, but I certainly haven't seen the issue on modern hardware.

comment:4 Changed 18 months ago by axeld

Owner: changed from axeld to nobody
Status: newassigned

comment:5 Changed 2 months ago by waddlesplash

Resolution: fixed
Status: assignedclosed

Well, presuming fixed then.

Note: See TracTickets for help on using tickets.