Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#374 closed bug (fixed)

screenshots have wrong filetype.

Reported by: mattmadia@… Owned by: axeld
Priority: low Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

noticed in hrev16493

all screenshots taken via PrintScreen button inherit a FileType of messag/rfc822 expected: image/png

steps to reproduce: hit PrintScreen Since the right-click FileType addon does not work, Open FileTypes from the preference menu. drag-n-drop a screenshot to see the incorrect filetype. drag-n-drop other files, text or apps to verify that drag-n-dropping files in FileTypes works properly.

Change History (5)

comment:1 Changed 13 years ago by mattmadia@…

this is from a linux-built haiku.image not tested on a BeOS-built image file.

comment:2 Changed 13 years ago by johndrinkwater

Could this be related to/duplicate of #194?

comment:3 Changed 13 years ago by axeld

Status: newclosed

comment:4 Changed 13 years ago by axeld

Resolution: fixed

comment:5 Changed 13 years ago by axeld

That's indeed the same bug as #194. However, we now (since hrev16954) write the file type directly, so that the broken file types under Linux don't have an influence on this anymore.

Note: See TracTickets for help on using tickets.