Opened 10 years ago

Closed 10 years ago

#3767 closed enhancement (fixed)

[PATCH] enhancements to DiskUsage

Reported by: stpere Owned by: axeld
Priority: normal Milestone: R1
Component: Applications Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

As said in others ticket (I hope this won't be considered as duplicates, sorry if it is) there are some usability issues with DiskUsage. My patch fixes two of those :

  • "Jigger" when resizing the window
  • Zoom button not working (in appearance, I know it does something, but it's not obvious)

So, basically, I just removed the proportion constraint on the window, which was working weird, and placed it on the pieView (to avoid having it clipped).

Resizing is now smooth and the Zoom button zooms to the largest square window displayable, which I think is what it should do.

I might tackle a few of the todos in that application.

Attachments (3)

patch_diskusage (6.1 KB) - added by stpere 10 years ago.
patch_diskusage_2 (7.5 KB) - added by stpere 10 years ago.
Additional enhancements
patch_diskusage_3 (7.7 KB) - added by stpere 10 years ago.

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by stpere

Attachment: patch_diskusage added

Changed 10 years ago by stpere

Attachment: patch_diskusage_2 added

Additional enhancements

comment:1 Changed 10 years ago by stpere

The second version of the patch further enhance DiskUsage so that clicking "Get Info" calls Tracker's GetInfo..

I didn't remove the old InfoWindow as it's used if the messenger can't find tracker. I wasn't sure if it was necessary to keep that old version (my intuition tells me it's cluttering the sources), but I kept it.

TODO : The old InfoWindow was positioned according to where you clicked. I didn't find a way with Tracker's GetInfo to get the same result.. Maybe I could add attributes to the BMessage passed to include the BPoint and modify tracker accordingly.

Changed 10 years ago by stpere

Attachment: patch_diskusage_3 added

comment:2 Changed 10 years ago by stpere

The third version of the patch also fixes drawing artefacts when moving around the info window. The issue is that there is a check in Draw() to not redraw if the updated area isn't intersecting with the pieView area.. problem is that we did an inset on that rect right before that check.. so if we had to redraw something in the margins of the pieview, it was skipped, leaving artefacts..

I just displaced the inset after the intersection check.

comment:3 Changed 10 years ago by stippi

Resolution: fixed
Status: newclosed

Applied in hrev30171.

Note: See TracTickets for help on using tickets.