Opened 10 years ago

Closed 10 years ago

#3795 closed bug (fixed)

Kinesis USB Keyboard on Non-Root Hub Doesn't Work in KDL

Reported by: bonefish Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Setup: Haiku hrev30247, gcc 4 build, Lenovo T61 with docking station, Kinesis USB keyboard plugged into non-root hub (in docking station).

When entering KDL via F12, neither the USB keyboard nor the PS/2 keyboard work. The USB keyboard works fine in KDL when plugged into a root hub, though.

~> listusb
0483:2016 /dev/bus/usb/0/1 "STMicroelectronics" "Biometric Coprocessor" ver. 0001
0000:0000 /dev/bus/usb/0/hub "HAIKU Inc." "UHCI RootHub" ver. 0110
0000:0000 /dev/bus/usb/1/hub "HAIKU Inc." "UHCI RootHub" ver. 0110
0000:0000 /dev/bus/usb/2/hub "HAIKU Inc." "UHCI RootHub" ver. 0110
0000:0000 /dev/bus/usb/3/hub "HAIKU Inc." "UHCI RootHub" ver. 0110
0000:0000 /dev/bus/usb/4/hub "HAIKU Inc." "UHCI RootHub" ver. 0110
046d:c03d /dev/bus/usb/5/3/1 "Logitech" "USB-PS/2 Optical Mouse" ver. 2000
05f3:0007 /dev/bus/usb/5/3/3/1 "" "" ver. 0310
05f3:0081 /dev/bus/usb/5/3/3/hub "" "" ver. 0310
04b3:4485 /dev/bus/usb/5/3/hub "" "" ver. 0001
0000:0000 /dev/bus/usb/5/hub "HAIKU Inc." "EHCI RootHub" ver. 0200
0000:0000 /dev/bus/usb/6/hub "HAIKU Inc." "EHCI RootHub" ver. 0200

Change History (2)

in reply to:  description comment:1 by mmlr, 10 years ago

Replying to bonefish:

Setup: Haiku hrev30247, gcc 4 build, Lenovo T61 with docking station, Kinesis USB keyboard plugged into non-root hub (in docking station).

This cannot work, as we don't support debug transfers in EHCI. The problem is that the device is a low-speed device behind a high-speed hub using a transaction translator. Supporting transfers like this in EHCI (and EHCI transfers in general) is quite a bit more involved than supporting them for UHCI.

Replying to bonefish:

When entering KDL via F12, neither the USB keyboard nor the PS/2 keyboard work. The USB keyboard works fine in KDL when plugged into a root hub, though.

That the PS/2 keyboard doesn't work anymore is fixed in hrev30265. In this case one of them should always work (either USB or PS/2).

Since I really don't see the effort to implement EHCI debug transfers as worth it, can you live with this situation? As at least one of the input methods should now always work this should be good enough.

comment:2 by bonefish, 10 years ago

Resolution: fixed
Status: newclosed

My main concern was really that the PS/2 keyboard didn't work either. So, if the EHCI support would be too much effort, I'm fine with how it works now.

Note: See TracTickets for help on using tickets.