Opened 13 years ago

Closed 11 years ago

#381 closed bug (fixed)

Bad port ID

Reported by: diver Owned by: bonefish
Priority: critical Milestone: R1
Component: System/Kernel Version:
Keywords: Cc: axeld
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by axeld)

after several apps launched i can't start any other app. All i get is a message

  • Bad port ID. Trying to start any app in terminale prints this error also.

Attachments (3)

Bad port ID.jpg (6.5 KB) - added by diver 13 years ago.
Bad port ID
Screenshot-QEMU.png (50.1 KB) - added by diver 12 years ago.
Screenshot-QEMU-1.png (79.7 KB) - added by diver 12 years ago.

Download all attachments as: .zip

Change History (19)

comment:1 Changed 13 years ago by axeld

I never had this, can you give more insight into your system configuration? Especially the amount of memory could be helpful.

Also, could you give more information on how to reproduce this? After how many apps does it usually happen, etc.

Changed 13 years ago by diver

Attachment: Bad port ID.jpg added

Bad port ID

comment:2 Changed 13 years ago by korli

I had this two times : seems the registrar was gone.

comment:3 Changed 13 years ago by diver

I have 256MB of RAM. It happens again with hrev17159. I launched BeMail and start to read my messages from R5 partition, suddenly Haiku became slow, after a minute i managed to start top in terminal to see what's happaning, it was BeMail who eats 98% of cpu with thread name - Reader. Then i killed it with Vulcan Death Grip and after that i couldn't start any apps anymore - Bad port ID. Hope this will help.

comment:4 Changed 13 years ago by korli

Could you check this bug again please ? Thanks.

comment:5 Changed 13 years ago by diver

(In reply to comment #5)

Could you check this bug again please ? Thanks.

I'll try, but i didn't find how to reproduce it, yet.

comment:6 Changed 13 years ago by axeld

Description: modified (diff)
Platform: All

It just happened to me again with the method described in bug #757. It seems the registrar just died silently, probably some kind of exception?

comment:7 Changed 13 years ago by axeld

Priority: normalcritical

comment:8 Changed 13 years ago by axeld

Owner: changed from axeld to bonefish

comment:9 Changed 12 years ago by diver

Happens to me again with hrev20130 under vmware with 128 of RAM after running 10 hours. I tried to launch Clock, but got an error Bad port ID. Then i tried to launch it from terminal and got this error: FATAL: be_roster is not valid. Is the registrar running? Checked for registrar in team monitor and it wasn't there, so yes, it seems the registrar died without any error.

comment:10 Changed 12 years ago by bonefish

Cc: axeld added

I haven't been able to reproduce the problem yet. The bug #757 method didn't cause any problems. Well, at least not for Haiku. qemu manages to freeze the X server everytime. Under vmware things work like a charm, though.

I wouldn't rule out that, as Axel suggested, the problem might be some uncaught C++ exception. In two central places I've added code to catch exceptions and call the debugger(). As of hrev20145 a registrar crash or debugger() call will always cause a consoled + gdb session to be entered. So it won't go unnoticed anymore (before a single line in the serial debug output was the only indication).

If it happens again (and indeed enters gdb) please send the serial debug output. If the registrar really hit a debugger() call, it can be continued by telling gdb to "detach" and then to "quit".

comment:11 Changed 12 years ago by diver

Start GLTeapot and hit alt+q, GLTeapot will crash with Bad port ID. Don't know if it related at all. Tested in qemu with hrev21586

comment:12 Changed 12 years ago by diver

Hmm, strange thing is that i get diffirent back traces, i will attach them as screenshots.

Changed 12 years ago by diver

Attachment: Screenshot-QEMU.png added

Changed 12 years ago by diver

Attachment: Screenshot-QEMU-1.png added

comment:13 Changed 12 years ago by bonefish

I still haven't been able to reproduce this bug (i.e. the registrar dying silently). The GLTeapot problems seem to be unrelated -- IIRC there even have been related fixes not too long ago.

comment:14 Changed 11 years ago by bonefish

Any news on this bug? I haven't seen it ever.

comment:15 Changed 11 years ago by diver

I didn't saw this bug since 02.14.2007, but i didn't run haiku naitve since than too.

comment:16 Changed 11 years ago by bonefish

Resolution: fixed
Status: newclosed

OK, thanks. I'll close it for the time being. If someone happens to be able to reproduce it still, please reopen it.

Note: See TracTickets for help on using tickets.