Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#3840 closed bug (invalid)

CD-ROM build broken

Reported by: haiqu Owned by: bonefish
Priority: normal Milestone: R1
Component: Build System Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

In the past 12 hours changes to the sources have resulted in the situation where CD-ROMs built will not even get to the splash screen.

I was able to build a bootable CD-ROM yesterday, about 25-30 revisions ago. I'm at hrev30477 right now.

I might also add that the tree structure of the CD build is out of sync with the install build ever since the restructure.

Change History (8)

comment:1 Changed 10 years ago by mmadia

Please do not report two distinctly different issues in the same bug report. File a second one and modify the description.

comment:2 in reply to:  description Changed 10 years ago by mmlr

Replying to haiqu:

In the past 12 hours changes to the sources have resulted in the situation where CD-ROMs built will not even get to the splash screen.

You could post the build output so it's easier to check. Please also provide the command line you used. As there are two CD targets for now (a pure boot CD part and an actual ISO-only Haiku CD), this is needed to see which one has issues.

I might also add that the tree structure of the CD build is out of sync with the install build ever since the restructure.

That shouldn't really be possible because it is using the exactly same HaikuImage rules as it's base.

comment:3 Changed 10 years ago by haiqu

Checked at hrev30496 and I can build a bootable CD again.

Apparent differences in the build were partially caused by the same fault that I reported in #3766 with the addition that some stuff was still included under the /boot/beos tree. That stuff is no longer visible in the hrev30496 build.

Please close, resolved.

comment:4 Changed 10 years ago by stippi

Resolution: invalid
Status: newclosed

The "update-all" target really has some side effects. It may look like there are problems, but they don't exist on a clean build.

comment:5 Changed 10 years ago by haiqu

Stippi, The update-all build target hasn't been available since before I started working on the modern Haiku, over a month ago. I use:

jam -q haiku-image

A complete clean build each time is out of the question, it would take too long. As it is, today's svn update invoked a 3960 file rebuild which will take an hour or so.

comment:6 Changed 10 years ago by umccullough

update-all is not a target, it's a build action. It's meant to be used with a build profile (very easy to setup in your UserBuildConfig).

In order to use it, you would invoke with:

jam -q @profilename update-all

where @profilename represents a build profile you have declared to either build an image (either raw or vmware), build to a partition device, or install to BFS directory (the last option is only available from beos-compatible hosts)

As stippi indicates, the update-all build action does have issues anyway.

comment:7 Changed 10 years ago by stippi

It looks to me like your original problem was that you installed a clean build (what you get from jam -q haiku-image) over an existing installation -- resulting in a mess after the directory restructuring we did, which you slowly resolved. I assumed you had reached this point by using "update-all". Looking from the point of the result, it's pretty much the same thing. ;-)

comment:8 Changed 10 years ago by haiqu

Au contraire. I predicted problems at the time of the directory changes and rebuilt cleanly to a different drive.

Note: See TracTickets for help on using tickets.