Opened 10 years ago

Closed 9 years ago

#3855 closed bug (fixed)

MediaPlayer doesn't play from file beginning

Reported by: marcusoverhagen Owned by: stippi
Priority: high Milestone: R1
Component: Applications/MediaPlayer Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When MediaPlayer is playing an avi file, and I drop a second avi file on the player window, the second file doesn't start playback from the beginning, but instead from somewhere in the middle.

Change History (6)

comment:1 by marcusoverhagen, 10 years ago

Owner: changed from marcusoverhagen to stippi

Perhaps you can fix this faster than I could.

comment:2 by stippi, 10 years ago

I can try... the problem is that sometimes the asynchronous playback manager gets in the way. The Controller tries to reset everything, but sometimes the values are reset in the PlaybackManager to old values from the previous stream.

comment:3 by axeld, 10 years ago

Priority: normalhigh
Version: R1/pre-alpha1R1/Development

This happens now much more often since the MediaPlayer remembers the previous playlist (which, btw, only works when you quit MediaPlayer by closing its window): if a playlist is already at its end, and you drop a new file/folder on MediaPlayer, it will try to continue to play at the old position from the last file.

Not sure if it's the same bug, though, but it's sure annoying.

comment:4 by streak, 10 years ago

Still present in #35878

comment:5 by axeld, 10 years ago

The issue my comment above referred to is fixed in hrev36224. From the code, I would say it cannot be related to the original problem, though.

Does that one still occur?

comment:6 by stippi, 9 years ago

Resolution: fixed
Status: newclosed

This one is fixed in hrev38551.

Note: See TracTickets for help on using tickets.