Opened 10 years ago

Closed 5 years ago

#3922 closed bug (invalid)

I can't connect with DHCP from ~r.30012

Reported by: Hubert Owned by: axeld
Priority: normal Milestone: R1
Component: Network & Internet/Stack Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

In r.29857 connect with DHCP -while boot Haiku- working correctly but between r.29857 and r.30012 create changes which prevented the connection with DHCP on my desktop (btw. on my laptop dhcp work correctly)

Attachments (4)

ifconfig1 (744 bytes) - added by Hubert 10 years ago.
r.30150 ifconfig
listdev (2.0 KB) - added by Hubert 10 years ago.
hrev30150 listdev
syslog (191.4 KB) - added by Hubert 10 years ago.
hrev30704
syslog30780 (284.1 KB) - added by Hubert 10 years ago.

Download all attachments as: .zip

Change History (24)

Changed 10 years ago by Hubert

Attachment: ifconfig1 added

r.30150 ifconfig

Changed 10 years ago by Hubert

Attachment: listdev added

hrev30150 listdev

comment:1 Changed 10 years ago by stippi

Hubert, we are already 550 revisions later! This problem has long been fixed. Please try again with a current revision and report if it works again for you.

comment:2 Changed 10 years ago by Hubert

stippi you have right but I tested last revision ~30680 (I don't rebember now) and the same problem, but I searching (building) last working correctly revision and now I have 2 revision on HDD: r.29857 (working DHCP) and hrev30150 (DHCP failed on my desktop). Today I compile newest revision and upload syslog.

comment:3 Changed 10 years ago by Hubert

I checked hrev30704 (gcc4 hybrid) and the same.

Changed 10 years ago by Hubert

Attachment: syslog added

comment:4 Changed 10 years ago by bga

Unfortunatelly I can not help much with this but at least I can say that my recent change to DHCP should not be the cause of this as it is only relevnt to machines with more than one network card. Does manually configuring an IP work?

comment:5 Changed 10 years ago by Hubert

Static IP don't work too. This only presumption. But problem from DHCP is since moment of change in structure of folders(/boot/beos/system on /boot/system) in Haiku, just after revision 29857...

comment:6 Changed 10 years ago by stippi

Hm. Can you explain your method if installation? What network driver do you use? This begins to sound like a problem of an "unclean" installation.

comment:7 Changed 10 years ago by Hubert

Hmm, with Haiku, Zeta (necessary makebootable with Haiku or change zbeos with haiku_loader) or Linux (precisely on USB Flash by dd). I remove old folder and transfer new. I use default driver for Realtek 8139. Image with haiku-files don't work correctly too. Interesting because when use the same usb flash with laptop (realtek 8139 too) dhcp and net work fine.

comment:8 Changed 10 years ago by bga

Just to make this clear, your problem is obviously not DHCP, but networking in general.

comment:9 Changed 10 years ago by Hubert

Yes, this is very possible. Can was somehow (config files etc.) extort launch of system from DHCP?

comment:10 Changed 10 years ago by Hubert

I made test:

I replace all folders and files from /boot/system/addons/kernel/network with rev. 30751 on files (and folders) from /boot/beos/system/addons/kernel/network with rev. 29857 (last revision with workong network at me), next I reboot system and I have DHCP and working network in r.30751. What was introduced or change in source between rev.29857 and rev.30751 ?

comment:12 Changed 10 years ago by Hubert

Found guilty: rev. 30000 and higer. Propably when Axel sockety changed to inherit from WeakRef then started to burst dhcp / network.

comment:13 Changed 10 years ago by zooey

As mentioned earlier by Stephan, we already new that hrev30000 is broken. That particular bug has been fixed in hrev30175.

comment:14 Changed 10 years ago by Hubert

This didn't repair my problem. I have the same in hrev30680, hrev30704 and hrev30775.

comment:15 Changed 10 years ago by bga

Hubert, did you d a *FULL* clean install to check? You mentioned erasing directories and recreating them again. This is not the best way to go for checking this. Also, did you try in recent version to see if you could configure a static IP? Based on your comments early in this ticket it seems DHCO is not the problem at all. The problem is simply that your network stack is not working (so, DHCP would not work either).

comment:16 Changed 10 years ago by Hubert

Now, I clear install hrev30780 with dd on USB stick. I will upload syslog. Configure with static IP doesn't give effect. The problem appear from hrev30000 and fixed with hrev30175 didn't help. Network not work. I have hrev29996 on HDD and his network work correctly.

Changed 10 years ago by Hubert

Attachment: syslog30780 added

comment:17 Changed 9 years ago by korli

Is this still valid ?

comment:18 Changed 9 years ago by Coldfirex

Hubert can you please retest with a recent build?

comment:19 Changed 8 years ago by Hubert

Gentlemen, I'll try to do it soon because we came with umccullough problem is with my card based on Realtek 8139 - who worked before without a problem. On my nForce ethernet work good. I must have some free time to test the card again.

comment:20 Changed 5 years ago by luroh

Resolution: invalid
Status: newclosed

Possibly fixed, closing due to lack of feedback.

Note: See TracTickets for help on using tickets.