Opened 10 years ago

Closed 4 years ago

#3974 closed bug (duplicate)

[Tracker] opening a folder in list view is slower than in icon view

Reported by: diver Owned by: aldeck
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/Development
Keywords: Cc:
Blocked By: #3011 Blocking:
Has a Patch: no Platform: All

Description

Opening a folder full of files is noticeably slower in listview compared to iconview. Examples:
open /system/bin (3s vs 1s)
open /system/documentation/bebook (5s vs 1s)

vbox 2.0.2, Haiku hrev30907

Change History (8)

comment:1 Changed 10 years ago by diver

Component: - GeneralApplications/Tracker

comment:2 Changed 10 years ago by axeld

Owner: changed from axeld to aldeck
Version: R1/pre-alpha1R1/Development

comment:3 Changed 9 years ago by diver

Still here in hrev35570.

comment:4 Changed 9 years ago by diver

Still here in hrev38300.

comment:5 Changed 6 years ago by diver

Summary: [Tracker] opening a folder in listview is slow[Tracker] opening a folder in list view is slower than in icon view

Still with us in hrev45736.

comment:6 Changed 5 years ago by diver

I noticed that if I resize a Tracker window to make it really small, where only one or two first items are visible, Tracker lists files almost instantly. The opposite is also true, the larger the window, the slower it loads the content.

comment:7 Changed 5 years ago by diver

Interestingly, there's no delay even in list view mode if scrollbar is at the bottom and Tracker window is showing last several items. It doesn't work with /bin since it's read-only but i can reproduce it with another writable folder with many files (e.g. /system/packages). Inefficient sorting algorithm?

comment:8 Changed 4 years ago by diver

Blocked By: 3011 added
Resolution: duplicate
Status: newclosed

Most likely a dupe of #3011.

Note: See TracTickets for help on using tickets.