Opened 10 years ago

Closed 8 years ago

Last modified 15 months ago

#3998 closed bug (invalid)

Failure to boot if vitrual memory set to more than available space

Reported by: dlmcpaul Owned by: leavengood
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

If the virtual memory setting is greater than the amount of space available on disk then haiku stops booting.

If there is not enough space for the swap file then it should be reduced or virtual memory turned off.

Failing to boot should not be an option.

How to reproduce: Increase Virtual Memory to > available disk space and reboot.

experience behaviour: Haiku fails to boot

expected behaviour: Haiku boots with reduced swap space.

Attachments (1)

syslog.zip (11.8 KB ) - added by dlmcpaul 10 years ago.
Syslog from booting system

Download all attachments as: .zip

Change History (8)

comment:1 by axeld, 10 years ago

I can't reproduce this over here. Booting always works fine.

Can you please provide syslog from a working run, and from one that doesn't boot? (a photo of the last two pages off on screen debug output would be great from the latter)

by dlmcpaul, 10 years ago

Attachment: syslog.zip added

Syslog from booting system

comment:2 by axeld, 10 years ago

Milestone: R1/alpha1R1

The syslog (unzipped would have been preferred for easier handling) from the booting system alone doesn't really help. In any case, since I cannot reproduce this, I don't think this deserves to be in the alpha milestone.

comment:3 by scottmc, 8 years ago

Does this still happen?

comment:4 by scottmc, 8 years ago

Blocking: 7665 added

comment:5 by leavengood, 8 years ago

Owner: changed from axeld to leavengood
Status: newassigned

Taking ownership.

comment:6 by leavengood, 8 years ago

Resolution: invalid
Status: assignedclosed

I couldn't reproduce this either, and I tried pretty hard.

For one thing, the VirtualMemory preflet will only let you set the swap size to a maximum of the available space on the drive (though even that should be reduced.)

Secondly, even if the virtual_memory settings file is modified to use a size greater than the available space, the VM system will fail in resizing the swap file, and even prints a syslog error saying so: "Failed to resize /var/swap to 3546991104 bytes: No space left on device".

So I'm pretty satisfied this can be closed.

comment:7 by waddlesplash, 15 months ago

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.