Opened 12 years ago

Last modified 3 years ago

#3999 closed bug

Boot hangs (with a twist) as uhci driver tries to take ownership — at Initial Version

Reported by: meianoite Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers Version: R1/pre-alpha1
Keywords: Cc: cpr420@…
Blocked By: Blocking:
Platform: All

Description

When I boot Haiku, the bootloader hangs on the third icon indefinitely. The first time I saw this I intended to reboot and enable the onscreen debug console, but for some reason I hit the power button instead of the reset one. And the boot continued!!

Puzzled, I rebooted, enabled the debug console, hit "p" to disable paging, and arrived at the text shown on the two attached pictures. "before" shows the kernel hung at the "usb ohci -1: smm is in control of the host controller" message. "after" shows what happens immediately after I hit the power button.

Syslog with timestamps is attached as well. But it's from a different session, as when I boot with onscreen debugging Haiku will hang on a black screen at the very end of the boot instead of going to the desktop (and that I tried using a FAT-formatted USB stick, but it KDL'd when I copied the syslog to it). Notice that for some unknown (to me) reason, the timestamps are within the same second, instead of being apart by the several minutes I waited between taking both screenshots (and hitting the power button, consequently). For example, JPEG EXIF data shows the "before" picture was taken at 16h18m44s, and the "after" picture at 16h21m18s. I guess what is timestamped is the buffer, and not the message itself.

Also attached is the output from dmesg from a verbose boot of FreeBSD on the same machine. Hope it helps.

I can of course change any compilation options to help debug this. The image is build on FreeBSD, but I've built Haiku on Haiku proper (yay!) and the same symptom shows. Makes no difference if I'm booting from a USB stick or from the hard drive (syslog is from a HD boot).

The motherboard BIOS is flashed to the latest version found on Asus' site. I have *no* idea why ACPI is showing _ASUS_ Notebook as the vendor identifier, as this is straight from Asus, flashed scratch with bootblock rewriting, ESCD cleared, CMOS cleared and everything I could think of to make it as pristine as possible, and not any modded/hacked BIOS.

I tried both with USB peripherals attached or detached; made no difference. Also tried inserting and removing peripherals while the boot is hung, no difference as well. There's one peripheral I couldn't detach, which is the RTL8187 WLAN interface that's build in on the motherboard; it connects straight to a special, internal USB header. I hope it's not the culprit, but still, only Haiku refuses to boot/requires hitting the power button in the middle of the boot process to continue loading, so...

Change History (4)

by meianoite, 12 years ago

Attachment: before.jpg added

Before hitting the power button

by meianoite, 12 years ago

Attachment: after.jpg added

After hitting the power button

by meianoite, 12 years ago

Attachment: syslog.txt added

Syslog, unfortunately not from the same session, but same symptoms

by meianoite, 12 years ago

Attachment: dmesg.txt added

Verbose 'dmesg' output from FreeBSD

Note: See TracTickets for help on using tickets.