Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#4011 closed bug (duplicate)

BFS-Errors if trash is emptied

Reported by: jahaiku Owned by: axeld
Priority: normal Milestone: R1
Component: File Systems/BFS Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: #3150 Blocking:
Has a Patch: no Platform: All

Description

This is gcc4 and new ATA build from friday evening on real hardware.

If I empty the trash with files in it, I see the following BFS-Error in syslog:

KERN: bfs: InitCheck:310: Bad data
KERN: bfs: inode at 1572866 is already deleted!

Change History (2)

comment:1 by axeld, 10 years ago

Blocked By: 3150 added
Resolution: duplicate
Status: newclosed

You obviously managed to corrupt your BFS disk (ie. you ran into some Haiku bug). Since this ticket does not contain any helpful information that distinct it from other tickets, I'll close it as a duplicate of #3150.

Please note that the "checkfs" utility should now be able to solve these problems (since hrev31775).

in reply to:  1 comment:2 by jahaiku, 10 years ago

Replying to axeld:

You obviously managed to corrupt your BFS disk (ie. you ran into some Haiku bug). Since this ticket does not contain any helpful information that distinct it from other tickets, I'll close it as a duplicate of #3150.

Only for info: As I remember this was a fresh install and then creating and deleting a little (Textfile with some bytes) file.

Note: See TracTickets for help on using tickets.