Opened 10 years ago

Closed 10 months ago

#4023 closed bug (fixed)

NumLock and CapsLock don't change keymap correctly

Reported by: humdinger Owned by: nobody
Priority: low Milestone: R1
Component: Drivers/Keyboard/PS2 Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev31031.

Pressing the NumLock key changes the keymap as expected. But pressing it again, thereby unlocking the num-pad, doesn't change the keymap back. That's only done after another key is pressed. (On my keyboard is a "Pause" key that acts under Haiku just like the NumLock key. Contrary to the above described, this one works as expected...)

Pressing the CapsLock key, does not change the keymap as expected. Only after pressing another key it will change. Pressing CapsLock again to unlock then works again as expected.

Change History (8)

comment:1 by axeld, 10 years ago

I cannot reproduce this with VMware at least. On what hardware are you testing? And is this a USB keyboard?

comment:2 by humdinger, 10 years ago

I see this behaviour in VirtualBox, but I just tried with a native Haiku and there NumLock and CapsLock work as expected. So, this bug is probably invalid.

I do still experience this:
"On my keyboard is a "Pause" key that acts under Haiku just like the NumLock key."

I have a notebook.

comment:3 by korli, 10 years ago

Resolution: invalid
Status: newclosed

comment:4 by korli, 10 years ago

Resolution: invalid
Status: closedreopened

sorry, didn't notice the line about Pause.

comment:5 by axeld, 10 years ago

Component: Preferences/Keymap- General
Version: R1/pre-alpha1R1/Development

But that would be a totally different issue; the keymap is then probably not correct.

comment:6 by pulkomandy, 5 years ago

Component: - GeneralDrivers/Keyboard/PS2

I get the same problem with Pause. Thinkpad X200, keyboard is wired to PS/2. I also see the left crtl key being enabled.

The handling of this key needs special care: " Pressing the dedicated Pause key on 101/102-key keyboards sends the same scancodes as pressing Ctrl, then NumLock, then releasing them in the reverse order would do; additionally, an E1hex prefix is sent which enables 101/102-key aware software to discern the two situations, while older software usually just ignores the prefix. The Pause key is different from all other keys in that it sends no scancodes at all on release; therefore it is not possible for any software to determine whether this key is being held down. "

(http://en.wikipedia.org/wiki/Break_key)

comment:7 by axeld, 3 years ago

Owner: changed from axeld to nobody
Status: reopenedassigned

comment:8 by humdinger, 10 months ago

Resolution: fixed
Status: assignedclosed

Can't reproduce anymore. Don't have the old notebook anymore. Seems to be fixed.

Note: See TracTickets for help on using tickets.