Opened 10 years ago

Closed 7 years ago

Last modified 10 months ago

#4041 closed bug (fixed)

no boot partition found while booting alpha-cd

Reported by: jahaiku Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

GCC4 build with new ATA-Stack of hrev31233 on real hardware. If I boot from the CD, with the internally cdrom drive, I get the error that no boot partition can be found.

Attachments (5)

haiku_cd_boot.jpg (173.0 KB) - added by jahaiku 10 years ago.
alpha-cd-fail-r36425.txt (14.9 KB) - added by cb88 9 years ago.
built gcc4 with 64bit and gcc2 under linux32 this was a gcc2hybrid
syslog (235.1 KB) - added by brunobratwurst 9 years ago.
P3 BX440 very slow booting ca.3min. Hd activity lamp remain lit&active.
listdev (1.2 KB) - added by brunobratwurst 9 years ago.
listdev of P3 440BX
listdev.2 (1.2 KB) - added by brunobratwurst 9 years ago.
listdev of P3 440BX

Download all attachments as: .zip

Change History (22)

Changed 10 years ago by jahaiku

Attachment: haiku_cd_boot.jpg added

comment:1 Changed 10 years ago by axeld

Component: - GeneralDrivers/Disk
Owner: changed from axeld to marcusoverhagen

I'm afraid we need a bit more information to make this a useful bug report, like: what kind of real hardware? A "listdev" output would be great. Also, does it boot with the old stack? Does it boot from HD? Is it a SATA or PATA CD-ROM?

comment:2 in reply to:  1 Changed 10 years ago by jahaiku

Replying to axeld:

I'm afraid we need a bit more information to make this a useful bug report, like: what kind of real hardware? A "listdev" output would be great. Also, does it boot with the old stack? Does it boot from HD? Is it a SATA or PATA CD-ROM?

The hardware is an old compaq notebook 17XL470 with PATA-cdrom. If I install Haiku on the HD it boots well from there. Is an lspci from Knoppix OK, too?

comment:3 Changed 10 years ago by axeld

Sure. Can you please also test booting with the old IDE stack?

comment:4 Changed 10 years ago by jahaiku

Here is the lspci output from knoppix:

00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ >SERR- <PERR- INTx-
	Latency: 64
	Region 0: Memory at f8000000 (32-bit, prefetchable) [size=64M]
	Capabilities: [a0] AGP version 1.0
		Status: RQ=32 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64- HTrans- 64bit- FW- AGP3- Rate=x1,x2
		Command: RQ=1 ArqSz=0 Cal=0 SBA- AGP- GART64- 64bit- FW- Rate=<none>
	Kernel driver in use: agpgart-intel

00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03) (prog-if 00 [Normal decode])
	Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 96
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
	I/O behind bridge: 00002000-00002fff
	Memory behind bridge: f4100000-f5ffffff
	Prefetchable memory behind bridge: 28000000-280fffff
	Secondary status: 66MHz+ FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
	BridgeCtl: Parity- SERR- NoISA- VGA+ MAbort- >Reset- FastB2B+
		PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-

00:07.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
	Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0

00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01) (prog-if 80 [Master])
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64
	Region 0: [virtual] Memory at 000001f0 (32-bit, non-prefetchable) [disabled] [size=8]
	Region 1: [virtual] Memory at 000003f0 (type 3, non-prefetchable) [disabled] [size=1]
	Region 2: [virtual] Memory at 00000170 (32-bit, non-prefetchable) [disabled] [size=8]
	Region 3: [virtual] Memory at 00000370 (type 3, non-prefetchable) [disabled] [size=1]
	Region 4: I/O ports at 1050 [size=16]
	Kernel driver in use: PIIX_IDE

00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01) (prog-if 00 [UHCI])
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 32
	Interrupt: pin D routed to IRQ 5
	Region 4: I/O ports at 1060 [size=32]
	Kernel driver in use: uhci_hcd

00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 03)
	Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Interrupt: pin ? routed to IRQ 9
	Kernel driver in use: piix4_smbus
	Kernel modules: i2c-piix4

00:08.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 01)
	Subsystem: Compaq Computer Corporation Device b103
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 168, Cache Line Size: 128 bytes
	Interrupt: pin A routed to IRQ 9
	Region 0: Memory at 28100000 (32-bit, non-prefetchable) [size=4K]
	Bus: primary=00, secondary=02, subordinate=05, sec-latency=176
	Memory window 0: 20000000-23fff000 (prefetchable)
	Memory window 1: 24000000-27fff000
	I/O window 0: 00001c00-00001cff
	I/O window 1: 00003000-000030ff
	BridgeCtl: Parity- SERR- ISA- VGA- MAbort- >Reset+ 16bInt+ PostWrite+
	16-bit legacy interface ports at 0001
	Kernel driver in use: yenta_cardbus
	Kernel modules: yenta_socket

00:09.0 Ethernet controller: Conexant HCF 56k Modem (rev 08)
	Subsystem: Compaq Computer Corporation 623-LAN Grizzly
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 160 (5000ns min, 10000ns max)
	Interrupt: pin A routed to IRQ 9
	BIST result: 00
	Region 0: I/O ports at 1400 [size=256]
	Region 1: Memory at f4000000 (32-bit, non-prefetchable) [size=16K]
	Capabilities: [58] Power Management version 2
		Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot+,D3cold+)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-
	Kernel driver in use: tulip
	Kernel modules: tulip

00:09.1 Communication controller: Conexant HCF 56k Modem (rev 05)
	Subsystem: Compaq Computer Corporation Yogi
	Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Interrupt: pin A routed to IRQ 9
	BIST result: 00
	Region 0: I/O ports at 1080 [size=8]
	Region 1: Memory at f4004000 (32-bit, non-prefetchable) [size=16K]
	Capabilities: [40] Power Management version 2
		Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot+,D3cold+)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:0a.0 Multimedia audio controller: ESS Technology ES1988 Allegro-1 (rev 12)
	Subsystem: Compaq Computer Corporation Device 002e
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64 (500ns min, 6000ns max)
	Interrupt: pin A routed to IRQ 5
	Region 0: I/O ports at 1800 [size=256]
	Capabilities: [c0] Power Management version 2
		Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA PME(D0-,D1+,D2+,D3hot+,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-
	Kernel driver in use: Maestro3
	Kernel modules: snd-maestro3

01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility P/M AGP 2x (rev 64) (prog-if 00 [VGA controller])
	Subsystem: Compaq Computer Corporation Device b18b
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping+ SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 66 (2000ns min), Cache Line Size: 32 bytes
	Interrupt: pin A routed to IRQ 10
	Region 0: Memory at f5000000 (32-bit, non-prefetchable) [size=16M]
	Region 1: I/O ports at 2000 [size=256]
	Region 2: Memory at f4100000 (32-bit, non-prefetchable) [size=4K]
	[virtual] Expansion ROM at 28000000 [disabled] [size=128K]
	Capabilities: [50] AGP version 1.0
		Status: RQ=256 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64- HTrans- 64bit- FW- AGP3- Rate=x1,x2
		Command: RQ=1 ArqSz=0 Cal=0 SBA- AGP- GART64- 64bit- FW- Rate=<none>
	Capabilities: [5c] Power Management version 1
		Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-
	Kernel modules: atyfb

comment:5 Changed 10 years ago by jahaiku

Here is listdev output from Haiku:

device Multimedia controller (Multimedia audio controller) [4|1|0]
  vendor 125d: ESS Technology
  device 1988: ES1988 Allegro-1

device Communication controller [7|80|0]
  vendor 14f1: Conexant Systems, Inc.
  device 1815: HCF 56k Modem

device Network controller (Ethernet controller) [2|0|0]
  vendor 14f1: Conexant Systems, Inc.
  device 1803: HCF 56k Modem

device Bridge (CardBus bridge) [6|7|0]
  vendor 104c: Texas Instruments
  device ac50: PCI1410 PC card Cardbus Controller

device Bridge [6|80|0]
  vendor 8086: Intel Corporation
  device 7113: 82371AB/EB/MB PIIX4 ACPI

device Serial bus controller (USB Controller, UHCI) [c|3|0]
  vendor 8086: Intel Corporation
  device 7112: 82371AB/EB/MB PIIX4 USB

device Mass storage controller (IDE interface) [1|1|80]
  vendor 8086: Intel Corporation
  device 7111: 82371AB/EB/MB PIIX4 IDE

device Bridge (ISA bridge) [6|1|0]
  vendor 8086: Intel Corporation
  device 7110: 82371AB/EB/MB PIIX4 ISA

device Display controller (VGA compatible controller, VGA controller) [3|0|0]
  vendor 1002: ATI Technologies Inc
  device 4c4d: Rage Mobility P/M AGP 2x

device Bridge (PCI bridge, Normal decode) [6|4|0]
  vendor 8086: Intel Corporation
  device 7191: 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge

device Bridge (Host bridge) [6|0|0]
  vendor 8086: Intel Corporation
  device 7190: 440BX/ZX/DX - 82443BX/ZX/DX Host bridge

comment:6 in reply to:  3 Changed 10 years ago by jahaiku

Replying to axeld:

Sure. Can you please also test booting with the old IDE stack?

OK, I try the old stack tonight

comment:7 Changed 10 years ago by jahaiku

Here are the results of the boot test from yesterday evening:

Boot from HD with old IDE: OK
Boot from HD with new ATA: OK
Boot from CDROM with old IDE: OK
Boot from CDROM with new ATA: Error as in the attached screenshot

comment:8 Changed 9 years ago by cb88

hrev36425 same thing happening in qemu-kvm tried without kvm as well.

serial log attached sent it to a terminal :-)

Changed 9 years ago by cb88

Attachment: alpha-cd-fail-r36425.txt added

built gcc4 with 64bit and gcc2 under linux32 this was a gcc2hybrid

comment:9 in reply to:  8 Changed 9 years ago by bonefish

Replying to cb88:

hrev36425 same thing happening in qemu-kvm tried without kvm as well.

If you've tested the trunk version, the regression was introduced in hrev36416 and fixed in hrev36429.

Don't know what's the state of this ticket.

comment:10 Changed 9 years ago by cb88

hrev36430 its booting fine here. Tracker did crash on me but that might be something I did. Everything else seems to work.

Changed 9 years ago by brunobratwurst

Attachment: syslog added

P3 BX440 very slow booting ca.3min. Hd activity lamp remain lit&active.

comment:11 Changed 9 years ago by brunobratwurst

Component: Drivers/Disk- General
Owner: changed from marcusoverhagen to nobody
Version: R1/pre-alpha1R1/alpha2

I have the same problem by using a second Hd with 150GB. I cannot use the first partition. Also I cannot use bootman because there is no 2KB space before the first boot partition. I can install Haiku R1Alpha2 to my second Hd but I cannot install a bootmanager nor Gparted(not running).

I can boot with the cd by pressing space, but boot secquence will take very long time on the 4th icon. Takes about 3min... to boot... before no problems with Zeta, BeOs.

Do I have to remove one drive? Think it doesnt work... Maybe the Hd is to big?

Changed 9 years ago by brunobratwurst

Attachment: listdev added

listdev of P3 440BX

Changed 9 years ago by brunobratwurst

Attachment: listdev.2 added

listdev of P3 440BX

comment:12 Changed 8 years ago by scottmc

Can you recheck this with a recent Haiku build?

comment:13 Changed 8 years ago by scottmc

Blocking: 7665 added

comment:14 Changed 7 years ago by diver

Can you still reproduce it?

comment:15 in reply to:  14 Changed 7 years ago by jahaiku

Replying to diver:

Can you still reproduce it?

NO, I think you can close it.

comment:16 Changed 7 years ago by diver

Resolution: fixed
Status: newclosed

Thanks for the feedback!

comment:17 Changed 10 months ago by waddlesplash

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.