Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#410 closed bug (fixed)

[FileTypes] BListView update several times

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

If you delete some type from FileTypes you will notice BlistView updates 3-4 times which causes high cpu usage. I think one update should be enough.

Change History (5)

comment:1 Changed 13 years ago by diver

Also on item remove next item should be selected and binding delete key to remove button would be useful too.

comment:2 Changed 13 years ago by axeld

You'd think, yes, but I refuse that feature request: you'll only rarely delete MIME types, there is no reason to ease navigation doing so, IMO.

But I'll look into the update thing :)

comment:3 Changed 13 years ago by axeld

This was obviously caused by the focus change due to the "Do you really want to remove this type?" alert and the bug in BListView::WindowActivated() which has been fixed in hrev17804.

comment:4 Changed 13 years ago by axeld

Resolution: fixed

comment:5 Changed 13 years ago by axeld

Status: newclosed
Note: See TracTickets for help on using tickets.