Opened 10 years ago

Closed 10 years ago

#4116 closed bug (fixed)

Unable to build libroot.so: Unexpected end of input.

Reported by: idefix Owned by: bonefish
Priority: normal Milestone: R1
Component: Build System Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: #4113 Blocking: #4117
Has a Patch: no Platform: All

Description

Recently, I'm unable to build libroot.so on Haiku. It always stops at the following error:

MkDir1 generated/objects/haiku/x86/common/system/libroot/os 
MkDir1 generated/objects/haiku_host/x86/release/tools/gensyscalls 
MkDir1 generated/objects/haiku/x86/common/tools/gensyscalls 
PreprocessSyscalls generated/objects/haiku/x86/common/tools/gensyscalls/syscalls.h.pp 
C++ generated/objects/haiku_host/x86/release/tools/gensyscalls/gensyscalls.o 
C++ generated/objects/haiku_host/x86/release/tools/gensyscalls/gensyscallinfos.o 
Link generated/objects/haiku_host/x86/release/tools/gensyscalls/gensyscallinfos 
Chmod1 generated/objects/haiku_host/x86/release/tools/gensyscalls/gensyscallinfos 
PreprocessSyscalls generated/objects/haiku/x86/common/tools/gensyscalls/syscalls.h.pp.parsable 
GenSyscallInfos1 generated/objects/haiku/x86/common/tools/gensyscalls/gensyscalls_infos.cpp 
Unexpected end of input.

generated/objects/haiku_host/x86/release/tools/gensyscalls/gensyscallinfos generated/objects/haiku/x86/common/tools/gensyscalls/syscalls.h.pp.parsable generated/objects/haiku/x86/common/tools/gensyscalls/gensyscalls_infos.cpp

...failed GenSyscallInfos1 generated/objects/haiku/x86/common/tools/gensyscalls/gensyscalls_infos.cpp ...
...skipped <src!tools!gensyscalls>gensyscalls_infos.o for lack of <src!tools!gensyscalls>gensyscalls_infos.cpp...
...skipped gensyscalls for lack of <src!tools!gensyscalls>gensyscalls_infos.o...
...skipped <syscalls>syscalls.S.inc for lack of gensyscalls...
...skipped <src!system!libroot!os>syscalls.o for lack of <syscalls>syscalls.S.inc...
...skipped os_main.o for lack of <src!system!libroot!os>syscalls.o...
...skipped libroot.so for lack of os_main.o...
...failed updating 1 target(s)...
...skipped 6 target(s)...
...updated 128 target(s)...

I'm experiencing this error in both of my build-environments: Haiku running in VMware and Haiku running on real hardware. Both of them using the gcc2 nightly builds from haiku-files.org. In both cases, I checked out a full tree before building.

Steps to reproduce in VMware:

  • Start an Haiku VMware environment with 2 virtual disks: an Haiku gcc2 VMware image from haiku-files.org and a 4 GB empty disk
  • Boot into the Haiku image and initialise the 4 GB disk with a block size of 1024 and no index
  • Checkout the Haiku tree to the 4 GB disk
  • Run configure and then build libroot.so

You should get the same build output as in this file.

Attachments (1)

builderror.txt (9.9 KB) - added by idefix 10 years ago.
Full build output when building libroot.so

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by idefix

Attachment: builderror.txt added

Full build output when building libroot.so

comment:1 Changed 10 years ago by jackburton

Blocking: 4117 added

comment:2 Changed 10 years ago by bonefish

Blocked By: 4113 added

I'd guess that this is a dup of #4113 and will disappear as soon as the build factory uses the correct build tools.

comment:3 Changed 10 years ago by idefix

It looks like Phil updated the Build Factory: the hrev31728 image got past the point of error without an error. :)

comment:4 Changed 10 years ago by idefix

...And it just finished building libroot.so without any errors! :)

This ticket can be closed.

comment:5 Changed 10 years ago by anevilyak

Will do as soon as we have confirmation that #4113 is resolved as well. Thanks!

comment:6 Changed 10 years ago by anevilyak

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.