Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#4128 closed bug (fixed)

[Tracker] CountView display question marks when using context search with some keymap

Reported by: diver Owned by: mmlr
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

CountView area in Tracker window shows question marks when I try to use context search (type ahead?)
Screenshot attached
Tested in hrev31799 in virtualbox

Attachments (3)

CountView.png (88.7 KB) - added by diver 10 years ago.
CountView2.png (1.4 KB) - added by diver 9 years ago.
CountView3.png (1.2 KB) - added by diver 9 years ago.

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by diver

Attachment: CountView.png added

comment:1 Changed 10 years ago by diver

Summary: [Tracker] CountView display question marks when using context search with russian keymap[Tracker] CountView display question marks when using context search with some keymap

comment:2 Changed 9 years ago by diver

Situation changed a bit, probably in hrev35375. After typing the first character it looks like this:


After typing the second (same) character it looks like this:


Tested with hrev35377 in VirtualBox 3.0.12

Changed 9 years ago by diver

Attachment: CountView2.png added

Changed 9 years ago by diver

Attachment: CountView3.png added

comment:3 Changed 9 years ago by mmlr

Owner: changed from axeld to mmlr
Status: newin-progress

Yup, the character now actually gets used in full whereas before it would cut off just the first byte and use that, resulting in a broken mutlibyte character. What you're seeing is probably a problem in TruncateString() and I'm about to investigate/fix that one (happens for any multibyte char apparently). The backend behind that truncation looks a bit, odd, to say the least.

comment:4 Changed 9 years ago by mmlr

Resolution: fixed
Status: in-progressclosed

Fixed in hrev35381 amongst other things.

comment:5 Changed 9 years ago by diver

Confirmed, thanks!

Note: See TracTickets for help on using tickets.