Opened 10 years ago

Closed 10 years ago

#4136 closed bug (duplicate)

DriveSetup: Partition menu options enabled in reverse order

Reported by: jonas.kirilla Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/DriveSetup Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I think some routine that enables/disables DriveSetup's Partition menu items has the order of the partitions reversed. (in hrev31644)

I have 4 primary partitions equally sized on a 40GB disk. All 4 partitions are BFS and healthy AFAIK.

BeOS, Bkp1, Bkp2, Haiku (/boot)

I would expect DriveSetup's Partition menu to have options initialize, delete and mount -disabled- for the boot partition (4), and enabled for the other three (unmounted) partitions.

I don't expect but do see these options enabled for the current Haiku boot partition (4) and disabled for the unmounted BeOS partition (1). Mounting partition (2) enables option to unmount partition (3).

Change History (1)

comment:1 Changed 10 years ago by mmadia

Resolution: duplicate
Status: newclosed

dupe of #3965

Note: See TracTickets for help on using tickets.