Opened 10 years ago

Closed 9 years ago

#4140 closed bug (fixed)

[app_server] crash in AppServer::ClientTeam

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by axeld)

I started all apps in Leaf menu->Preferences and started to close them quickly after they all have been loaded and got a crash.
This is hrev31840 in virtualbox

Attachments (4)

app_server.png (14.9 KB) - added by diver 10 years ago.
app_server2.png (19.9 KB) - added by diver 10 years ago.
app_server3.png (16.7 KB) - added by diver 10 years ago.
app_server4.png (14.1 KB) - added by diver 10 years ago.

Download all attachments as: .zip

Change History (14)

Changed 10 years ago by diver

Attachment: app_server.png added

comment:1 Changed 10 years ago by diver

Ah damn, it seems I forgot close bracket in Image(app_server.png?

comment:2 Changed 10 years ago by diver

First backtrace


And I just get another crash in hrev31894

Changed 10 years ago by diver

Attachment: app_server2.png added

comment:3 Changed 10 years ago by axeld

Description: modified (diff)

comment:4 Changed 10 years ago by axeld

How did you close the apps? I can't reproduce this.

comment:5 Changed 10 years ago by diver

Clicking random app window and pressing alt+w shortcut very fast. I'll try to reproduce it again myself.

comment:6 Changed 10 years ago by diver

I just tried and now it crashed with a different backtrace, looks like #3066

comment:7 Changed 10 years ago by diver

Changed 10 years ago by diver

Attachment: app_server3.png added

comment:8 Changed 10 years ago by diver

Another crash when I tried to reproduce it in vmware player

Changed 10 years ago by diver

Attachment: app_server4.png added

comment:9 Changed 9 years ago by diver

Can't reproduce it, probably fixed. Feel free to close.

comment:10 Changed 9 years ago by anevilyak

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.