Opened 13 years ago

Closed 12 years ago

#417 closed bug (fixed)

[kernel] PANIC: vm_page_fault...

Reported by: diver Owned by: axeld
Priority: blocker Milestone: R1
Component: System/Kernel Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by axeld)

You could crash haiku if you go to the /boot/beos/system/lib select all and press enter several times. Sometims it's just lib, that crash. I know i shouldn't launch libs, but this may uncover some deeper bugs. back traces will follow. Tested under vmware with rev17009.

Attachments (4)

panic.PNG (23.1 KB) - added by diver 13 years ago.
back trace in kdl
libmidi.PNG (42.3 KB) - added by diver 13 years ago.
back trace
alert.PNG (4.9 KB) - added by diver 13 years ago.
too many files
kdl_3.PNG (24.8 KB) - added by diver 13 years ago.
kdl

Download all attachments as: .zip

Change History (9)

Changed 13 years ago by diver

Attachment: panic.PNG added

back trace in kdl

Changed 13 years ago by diver

Attachment: libmidi.PNG added

back trace

comment:1 Changed 13 years ago by axeld

I can't reproduce this bug. I had a deviation of this (an area/vm_cache with wrong ref_count) some time ago, but I couldn't reproduce this either. IOW there is some hard to track bug in the reference counting of areas or vm_caches.

I've changed the runtime_loader's test_executable() function to choke on libraries already, so they are no longer executed at all.

Changed 13 years ago by diver

Attachment: alert.PNG added

too many files

comment:2 Changed 13 years ago by diver

(In reply to comment #3)

I can't reproduce this bug. I had a deviation of this (an area/vm_cache with wrong ref_count) some time ago, but I couldn't reproduce this either. IOW

there

is some hard to track bug in the reference counting of areas or vm_caches.

I can reproduce it if i go to /boot/beos/bin folder, select all and press enter several(3-5) times. Could you investigate this, Axel? Tested with rev17117 under vmware. P.S. Shouldn't tracker show alert window in such situations, smth like this (You are trying top open ##files, are you sure?)

comment:3 Changed 13 years ago by diver

Summary: PANIC: vm_page_fault...[kernel] PANIC: vm_page_fault...

Changed 13 years ago by diver

Attachment: kdl_3.PNG added

kdl

comment:4 Changed 13 years ago by axeld

Description: modified (diff)
Platform: All
Priority: normalblocker

comment:5 Changed 12 years ago by axeld

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.