Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#4182 closed bug (fixed)

Trying to play WMV files crashes MediaPlayer

Reported by: koki Owned by: stippi
Priority: normal Milestone: R1
Component: Applications/MediaPlayer Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I have several WMV vide files that MediaPlayer was capable of playing nicely until as recently as a couple of weeks ago that now crash MediaPlayer. This is on hrev32106. 100% reproducible.

Backtrace attached.

Attachments (1)

2009-08-03_bt-wmv-crash-mediaplayer (3.0 KB) - added by koki 9 years ago.
Backtrace

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by koki

Backtrace

comment:1 Changed 9 years ago by stippi

Can you make one of these files available to me somehow?

comment:2 Changed 9 years ago by stippi

Owner: changed from marcusoverhagen to stippi
Status: newassigned

Never mind, I found a file here myself. The debugger message also clearly says what's wrong, I just have to figure out where I messed up. Seems to be the refactoring of the AVCodecDecoder format negotiation...

comment:3 Changed 9 years ago by stippi

Resolution: fixed
Status: assignedclosed

Should be fixed in hrev32107. Sorry for the trouble, must have slipped in a line of code while I was already half asleep or something...

comment:4 Changed 9 years ago by koki

Confirming that this is fixed as tested on hrev32110. Thank you Stippi (and no need to apologize)! :)

Note: See TracTickets for help on using tickets.