Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#419 closed bug (fixed)

[PackageBuilder] Segment violation

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

PackageBuilder crashes on adding files:

GNU gdb 6.3 Copyright 2004 Free Software Foundation, Inc. GDB is free software, covered by the GNU General Public License, and you are welcome to change it and/or distribute copies of it under certain conditions. Type "show copying" to see the conditions. There is absolutely no warranty for GDB. Type "show warranty" for details. This GDB was configured as "i586-pc-haiku"...(no debugging symbols found)

Thread 553 caused an exception: Segment violation Reading symbols from /boot/beos/system/lib/libbe.so...(no debugging symbols found)...done. Loaded symbols for /boot/beos/system/lib/libbe.so Reading symbols from /boot/beos/system/lib/libtracker.so...(no debugging symbols found)...done. Loaded symbols for /boot/beos/system/lib/libtracker.so Reading symbols from /boot/beos/system/lib/libtranslation.so... (no debugging symbols found)...done. Loaded symbols for /boot/beos/system/lib/libtranslation.so Reading symbols from /boot/beos/system/lib/libnet.so...(no debugging symbols found)...done. Loaded symbols for /boot/beos/system/lib/libnet.so Reading symbols from /boot/beos/system/lib/libroot.so...done. Loaded symbols for /boot/beos/system/lib/libroot.so Reading symbols from /boot/beos/system/lib/libstdc++.hrev4.so...done. Loaded symbols for /boot/beos/system/lib/libstdc++.hrev4.so Reading symbols from /boot/beos/system/lib/libsocket.so...done. Loaded symbols for /boot/beos/system/lib/libsocket.so

[Switching to team /BeBox/develop/PackageBuilder/P (548) thread Status "Untitled 1" (553)] 0x006fef6e in strdup () from /boot/beos/system/lib/libroot.so (gdb) bt #0 0x006fef6e in strdup () from /boot/beos/system/lib/libroot.so #1 0x003a9e14 in BStatusBar::SetTextData ()

from /boot/beos/system/lib/libbe.so

#2 0x003a9867 in BStatusBar::Reset () from /boot/beos/system/lib/libbe.so #3 0x0023c2f0 in GStatusView::MessageReceived () #4 0x00266c55 in StatusView::MessageReceived () #5 0x00343263 in BLooper::DispatchMessage ()

from /boot/beos/system/lib/libbe.so

#6 0x003bd651 in BWindow::DispatchMessage ()

from /boot/beos/system/lib/libbe.so

#7 0x003c068c in BWindow::task_looper () from /boot/beos/system/lib/libbe.so #8 0x003447eb in BLooper::_task0_ () from /boot/beos/system/lib/libbe.so #9 0x006b0850 in thread_entry () from /boot/beos/system/lib/libroot.so #10 0x7003ffec in ?? () (gdb)

Change History (11)

comment:1 Changed 13 years ago by jackburton

Status: newclosed

comment:2 Changed 13 years ago by jackburton

* This bug has been marked as a duplicate of #326 *

comment:3 Changed 13 years ago by jackburton

Resolution: duplicate

comment:4 Changed 13 years ago by diver

Resolution: duplicate

comment:5 Changed 13 years ago by diver

It looks like this bug is not related to http://haiku-os.org/bugzilla/show_bug.cgi?id=326 Even though #326 is fixed PackageBuilder sill crashes with the same back trace. Reopening.

comment:6 Changed 13 years ago by diver

Status: closedreopened

comment:7 Changed 13 years ago by jackburton

Can you check if it's fixed now ? BTW, what is packagebuilder and where do I get it?

comment:8 Changed 13 years ago by axeld

It's part of the standard developer tools - the counterpart to SoftwareValet. It might be on your hard drive already :-)

comment:9 Changed 13 years ago by diver

(In reply to comment #3)

Can you check if it's fixed now ? BTW, what is packagebuilder and where do I get it?

Nope, it's not fixed:

Thread 1290 caused an exception: Segment violation Reading symbols from /boot/beos/system/lib/libbe.so...(no debugging symbols found)...done. Loaded symbols for /boot/beos/system/lib/libbe.so Reading symbols from /boot/beos/system/lib/libtracker.so...(no debugging symbols found)...done. Loaded symbols for /boot/beos/system/lib/libtracker.so Reading symbols from /boot/beos/system/lib/libtranslation.so... (no debugging symbols found)...done. Loaded symbols for /boot/beos/system/lib/libtranslation.so Reading symbols from /boot/beos/system/lib/libnet.so...(no debugging symbols found)...done. Loaded symbols for /boot/beos/system/lib/libnet.so Reading symbols from /boot/beos/system/lib/libroot.so...done. Loaded symbols for /boot/beos/system/lib/libroot.so Reading symbols from /boot/beos/system/lib/libstdc++.hrev4.so...done. Loaded symbols for /boot/beos/system/lib/libstdc++.hrev4.so Reading symbols from /boot/beos/system/lib/libsocket.so...done. Loaded symbols for /boot/beos/system/lib/libsocket.so

[Switching to team /BeBox/develop/PackageBuilder/P (1285) thread Status "Untitled 1" (1290)] 0x003aaa2b in BStatusBar::SetTextData () from /boot/beos/system/lib/libbe.so (gdb) bt #0 0x003aaa2b in BStatusBar::SetTextData ()

from /boot/beos/system/lib/libbe.so

#1 0x003aa487 in BStatusBar::Reset () from /boot/beos/system/lib/libbe.so #2 0x0023c2f0 in GStatusView::MessageReceived () #3 0x00266c55 in StatusView::MessageReceived () #4 0x00343703 in BLooper::DispatchMessage ()

from /boot/beos/system/lib/libbe.so

#5 0x003be2f1 in BWindow::DispatchMessage ()

from /boot/beos/system/lib/libbe.so

#6 0x003c131c in BWindow::task_looper () from /boot/beos/system/lib/libbe.so #7 0x00344c8b in BLooper::_task0_ () from /boot/beos/system/lib/libbe.so #8 0x006b18b0 in thread_entry () from /boot/beos/system/lib/libroot.so #9 0x7003ffec in ?? () (gdb)

comment:10 Changed 13 years ago by axeld

Resolution: fixed

Fixed in hrev17857.

comment:11 Changed 13 years ago by axeld

Status: reopenedclosed
Note: See TracTickets for help on using tickets.