Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#421 closed bug (duplicate)

[BeIDE] Segment violation

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

BeIDE crash if you go to preferences->key binding

GNU gdb 6.3 Copyright 2004 Free Software Foundation, Inc. GDB is free software, covered by the GNU General Public License, and you are welcome to change it and/or distribute copies of it under certain conditions. Type "show copying" to see the conditions. There is absolutely no warranty for GDB. Type "show warranty" for details. This GDB was configured as "i586-pc-haiku"...(no debugging symbols found)

Thread 478 caused an exception: Segment violation Reading symbols from /boot/beos/system/lib/libtracker.so...(no debugging symbols found)...done. Loaded symbols for /boot/beos/system/lib/libtracker.so Reading symbols from /boot/beos/system/lib/libmedia.so...(no debugging symbols found)...done. Loaded symbols for /boot/beos/system/lib/libmedia.so Reading symbols from /boot/beos/system/lib/libbe.so... (no debugging symbols found)...done. Loaded symbols for /boot/beos/system/lib/libbe.so Reading symbols from /boot/beos/system/lib/libroot.so...done. Loaded symbols for /boot/beos/system/lib/libroot.so Reading symbols from /boot/beos/system/lib/libnet.so...done. Loaded symbols for /boot/beos/system/lib/libnet.so Reading symbols from /boot/beos/system/lib/libtranslation.so...done. Loaded symbols for /boot/beos/system/lib/libtranslation.so Reading symbols from /boot/beos/system/lib/libstdc++.hrev4.so...done. Loaded symbols for /boot/beos/system/lib/libstdc++.hrev4.so Reading symbols from /boot/beos/system/lib/libsocket.so...done. Loaded symbols for /boot/beos/system/lib/libsocket.so Reading symbols from /BeBox/develop/BeIDE/plugins/Prefs_add_ons/MWBResPlugin...done. Loaded symbols for /BeBox/develop/BeIDE/plugins/Prefs_add_ons/MWBResPlugin Reading symbols from /BeBox/develop/BeIDE/plugins/Prefs_add_ons/ShellPlugin...done. Loaded symbols for /BeBox/develop/BeIDE/plugins/Prefs_add_ons/ShellPlugin Reading symbols from /BeBox/develop/BeIDE/plugins/Prefs_add_ons/gccPlugin...done. Loaded symbols for /BeBox/develop/BeIDE/plugins/Prefs_add_ons/gccPlugin Reading symbols from /BeBox/develop/BeIDE/plugins/Editor_add_ons/Commenter...done. Loaded symbols for /BeBox/develop/BeIDE/plugins/Editor_add_ons/Commenter

[Switching to team /BeBox/develop/BeIDE/BeIDE (472) thread Environment Preferences (478)] 0x0083eb67 in memmove () from /boot/beos/system/lib/libroot.so (gdb) bt #0 0x0083eb67 in memmove () from /boot/beos/system/lib/libroot.so #1 0x00694b91 in BMessage::_ResizeData () from /boot/beos/system/lib/libbe.so #2 0x006954ff in BMessage::ReplaceData () from /boot/beos/system/lib/libbe.so #3 0x006981ff in BMessage::ReplaceData () from /boot/beos/system/lib/libbe.so #4 0x0030fd52 in IDEApp::GetData () #5 0x002988f2 in MEnvironmentPreferencesWindow::GetTargetData () #6 0x00297d79 in MPreferencesWindow::GetDataForCurrentView () #7 0x00296e47 in MPreferencesWindow::ChangeView () #8 0x002968f6 in MPreferencesWindow::MessageReceived () #9 0x0068f263 in BLooper::DispatchMessage ()

from /boot/beos/system/lib/libbe.so

#10 0x00709651 in BWindow::DispatchMessage ()

from /boot/beos/system/lib/libbe.so

#11 0x0070c68c in BWindow::task_looper () from /boot/beos/system/lib/libbe.so #12 0x006907eb in BLooper::_task0_ () from /boot/beos/system/lib/libbe.so #13 0x007f0850 in thread_entry () from /boot/beos/system/lib/libroot.so #14 0x70080fec in ?? () (gdb)

Change History (3)

comment:1 Changed 13 years ago by mmlr

Status: newclosed

comment:2 Changed 13 years ago by mmlr

Resolution: duplicate

comment:3 Changed 13 years ago by mmlr

* This bug has been marked as a duplicate of #314 *

Note: See TracTickets for help on using tickets.