Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4215 closed bug (fixed)

MediaPlayer outputs only black frame when Acceleration is enabled

Reported by: jahaiku Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Graphics/intel_extreme Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Since my new gcc4 build from friday evening I have the same for every video I try to view.
If I disable the Hardware-Acceleration in the MediaPlayer options I have the correct display,
if I enable it I only see a black window.
But I have the black frame from the beginning of the video on.

There is no syslog output.

Attachments (1)

syslog (93.3 KB ) - added by jahaiku 10 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 by axeld, 10 years ago

There is always syslog output (unless you disabled it yourself, that is): please attach your /var/log/syslog file to this ticket. Since this is not a problem for everyone, it most probably a driver problem.

Does VLC work with overlay okay on that hardware?

by jahaiku, 10 years ago

Attachment: syslog added

comment:2 by jahaiku, 10 years ago

OK I have attached the syslog.
I have tested with gcc2 build from Haiku-Site.
I get the same black window in VLC, too. If I disable in MediaPlayer the acceleration video is OK.
The hardware is an EeePC 4G.

comment:3 by tokyo6pm, 10 years ago

I get the same black window in MediaPlayer and VLC on my Lenovo S10-2 when overlay is enabled.

comment:4 by axeld, 10 years ago

Component: Applications/MediaPlayerDrivers/Graphics/intel_extreme
Owner: changed from marcusoverhagen to axeld

Ah, that explains it; I might disable overlay for now for some chipsets.

comment:5 by HaikuBot, 10 years ago

Me too get the same black window in MediaPlayer/VLC.

comment:6 by umccullough, 10 years ago

I think at least overlay doesn't currently work on my Acer Aspire One with the i945 chip :(

comment:7 by mmlr, 10 years ago

I'm seeing the same on my laptop that has an i965GM. All overlays stay black. I am pretty certain that overlay worked on this laptop in the (recent) past, as I remember turning it off in VLC due to #3282. On my desktop that has G33 onboard graphics, overlay still works fine in VLC, and mostly fine in MediaPlayer. Some videos there produce corrupted output (but it doesn't stay black), but I guess this is a MediaPlayer bug I will file separately.

in reply to:  7 comment:8 by mmlr, 10 years ago

Replying to mmlr:

I'm seeing the same on my laptop that has an i965GM. All overlays stay black. I am pretty certain that overlay worked on this laptop in the (recent) past

Scratch that, it's getting late and I'm mixing up laptops. I've tested a few older revisions and none worked. So it's likely it never worked on this chip and I'm just mixing it up with the other laptop that has a radeon card. But the G33 part is still valid, it works there with hrev32211.

comment:9 by axeld, 10 years ago

Resolution: fixed
Status: newclosed

I disabled overlay for the reported cards. I can only confirm it works fine on i865, and G33. I also have a i965 where it worked at some point, but I can't test this right now (and in the next weeks).

comment:10 by scottmc, 10 years ago

I had the same issue with a couple of laptops. I disabled the overlay in the media player settings but it was still there. The same binary worked fine on some intel PCs, but not on either of the AMD64 PCs I tried it on. One of the AMD64 PCs has an ATI Radeon in it, while the other has a newer nvidia that falls back to VESA mode. Could there be some Intel specific code causing this?

comment:11 by umccullough, 10 years ago

Just a note, I looked at Scott's problem and while it seems to have the same result (black screen in media player with any video), it doesn't change with/without overlay enabled.

Thus, his issue seems to be a different bug with similar symptoms.

Note: we did not test to see if every video codec causes the same problem, I theorized perhaps our current ffmpeg settings might not be compatible with his amd64 processor, but I cannot confirm this personally at this time.

Scott, create a new ticket and I'll try to find an AMD machine to test this on as well.

comment:12 by scottmc, 10 years ago

A fresh build later (hrev32410) and mediaplayer is no longer doing the stuck on a black frame thing for me. I'll try it on the other AMD laptop and if that one works then there won't be a need for that new ticket.

Note: See TracTickets for help on using tickets.