Opened 10 years ago

Closed 10 years ago

#4230 closed bug (fixed)

[Deskbar] Vulcan Death Grip no longer work

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Deskbar Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking: #4951
Has a Patch: no Platform: All

Description

It seems I can't kill any app using Vulcan Death Grip. Tested in VirtualBox 3.0.4 and VMplayer 2.5.2. I would like to have this regression fixed before alpha if possible.

Change History (14)

comment:1 by humdinger, 10 years ago

It's still there, though IIRC it was done with a different under BeOS. I may remember it wrong though.

In Haiku it's COMMAND+OPT+SHIFT+click-on-Deskbar-entry. On my German keymap that's ALT+AltGr+Shift.

comment:2 by diver, 10 years ago

Just to be sure it's not a bug in my custom image I downloaded http://haiku-files.org/vm/haiku-pre-alpha-r32334-vm.zip and can't kill anything using VDG.

comment:3 by humdinger, 10 years ago

Open the keymap preferences and have a look where your CMD and OPT keys are. The American keymap, for example, has its OPT key mapped to the WIN key (on my keyboard).

comment:4 by diver, 10 years ago

As I've used default image an American keymap was used to test it.

comment:5 by anevilyak, 10 years ago

Hm... right win + right alt + right shift works for me here on american layout.

comment:6 by axeld, 10 years ago

Resolution: invalid
Status: newclosed

I guess diver is testing with a US internal keymap or vice versa.

comment:7 by diver, 10 years ago

No, it seems that I used to press win + alt + shift + ctrl, and it always worked in BeOS and also in Haiku at least until 2-3 months ago. Should we reopen this ticket?

comment:8 by humdinger, 10 years ago

I'm not sure. Three modifiers seem to be complicated enough already... If it's changed, CTRL+OPT+ALT might be easier on the fingers. Don't care too much either way, however.

comment:9 by diver, 10 years ago

Resolution: invalid
Status: closedreopened

Ok, it took me some hours, but using binary search I've finally nailed down to hrev31785.

comment:10 by stippi, 10 years ago

Thanks for tracking this down and sorry for the inconvenience. In my defense, the Vulcan Death Grip still works for me, but I have Ctrl and Alt modifiers swapped. In my case, I have to press all the modifiers in the left-bottom corner, that's shift-ctrl-windows, in another words shift-command-option in Haiku terminology.

comment:11 by stippi, 10 years ago

Oh, actually, it still works also with modifiers in "Haiku-mode". Then you have to press shift-windows-alt, ie. also shift-option-command, as before. The modifiers for the VDG follow the switch. Pressing four modifiers instead of the actual three worked for you before my changeset, because now the app_server grabs the events where control and alt are pressed at the same time. So the fix could be to grab these events only, if exactly those two modifiers are pressed, and no other ones. Although I would want it to work still with caps-lock and num-lock on.

comment:12 by diver, 10 years ago

It's working again, thanks!

comment:13 by stippi, 10 years ago

Resolution: fixed
Status: reopenedclosed

Yes, thanks for the notification! Fixed for good in hrev33459.

comment:14 by humdinger, 10 years ago

Blocking: 4951 added

(In #4951) #4230 dealt with the same thing. From the last comments there, it looks like it should have been fixed. If you feel it merits re-opening...
Personally, I don't care much which keys are used exactly, as long as the vulcan death grip still works somehow. Having SHIFT+CTRL+OPT+COMMAND is actually easier to remember as those are all modifier keys on the left side.

Note: See TracTickets for help on using tickets.