Opened 10 years ago

Closed 10 years ago

#4250 closed bug (fixed)

[Keymap] pressing shift doesn't show uppercase characters if KeymapSwitcher is installed

Reported by: diver Owned by: siarzhuk
Priority: normal Milestone: R1
Component: Preferences/Keymap Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #5122
Has a Patch: no Platform: All

Description

Keymap preflet doesn't show upper case characters, it used to work until Keymap rewrite.
Tested in hrev32436 in VirtualBox 3.0.4.

Change History (12)

comment:1 by stpere, 10 years ago

It seems to work here. Do you have a specific keymap where it doesn't work or any tip to reproduce the error? I know it can be hard to tell if it never works on your configuration..

comment:2 by diver, 10 years ago

Summary: [Keymap] pressing shift doesn't show upper case characters[Keymap] pressing shift doesn't show uppercase characters

I tried to remove Keymap settings:
rm ~/config/settings/Key_map
Launched Keymap and selected "American" and still can't see uppercase characters.

comment:3 by diver, 10 years ago

Clicking Shift button in the Keymap preflet do show uppercase characters. Should it show it if you press actual keyboard shift button?

comment:4 by axeld, 10 years ago

It should always show them, and also does that over here :-)

comment:5 by diver, 10 years ago

Strange, I could only reproduce it when I used my attachment:ticket:4306:UserBuildConfig

comment:6 by stippi, 10 years ago

Resolution: invalid
Status: newclosed

That sounds like it is a user error then. Maybe you have a messed up keymap or something, which you copy in your UserBuildConfig.

comment:7 by diver, 10 years ago

Resolution: invalid
Status: closedreopened
Summary: [Keymap] pressing shift doesn't show uppercase characters[Keymap] pressing shift doesn't show uppercase characters if KeymapSwitcher is installed

I've found the cause of this behavior by commenting out every line in my UserBuildConfig. It turns out it is KeymapSwitcher that blocks uppercase characters in Keymap preflet.
As soon as I move /boot/common/add-ons/input_server/filters/keymap_switcher to desktop everything is working OK.
Reopening... Siarzhuk :-) ?

comment:8 by anevilyak, 10 years ago

Blocking: 5122 added

(In #5122) Thanks diver!

comment:9 by diver, 10 years ago

Version: R1/pre-alpha1R1/Development

in reply to:  7 comment:10 by siarzhuk, 10 years ago

Owner: changed from axeld to siarzhuk
Status: reopenedassigned

Replying to diver:

It turns out it is KeymapSwitcher that blocks uppercase characters in Keymap preflet.
Reopening... Siarzhuk :-) ?

Hm... Really, looks "my" one. :-\

comment:11 by siarzhuk, 10 years ago

Fixed in KeymapSwitcher 1.2.5 that will be available soon as Optional Package.

comment:12 by siarzhuk, 10 years ago

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.