Opened 10 years ago

Closed 10 years ago

#4266 closed bug (fixed)

[Drupal] favicon and Firefox

Reported by: diver Owned by: haiku-web
Priority: normal Milestone: R1
Component: Website/CMS Version: R1/pre-alpha1
Keywords: Cc: umccullough
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Something is wrong with http://www.haiku-os.org/favicon.ico
If you try to open it in Firefox (BeZillaBrowser) it will ask you to save it instead of opeinng it in browser as any other image.
This leads to the fact, that that if www.haiku-os.org is set as BeZillaBrowser bookmark it will not have an icon.

Attachments (1)

missing_favicon_from_bookmark_panel.png (53.9 KB) - added by diver 10 years ago.

Download all attachments as: .zip

Change History (23)

comment:1 Changed 10 years ago by jonas.kirilla

The data is fine, but it seems like the server thinks it's text/plain.

/boot/home> wget -v http://www.haiku-os.org/favicon.ico
 ...
Length: 1,150 [text/plain]

comment:2 Changed 10 years ago by umccullough

Cc: umccullough added

Looks like this is not an uncommon issue. Checking a few other websites I found some that seem to have the same problem.

I'll take a look at it later on when I get a chance to ssh into the server.

comment:3 Changed 10 years ago by koki

Added the image/x-icon MIME type to .htaccess, and the problem you reported seems to be fixed now.

Please retest (you may want to clear you cache, just in case).

comment:4 in reply to:  3 ; Changed 10 years ago by leavengood

Replying to koki:

Added the image/x-icon MIME type to .htaccess, and the problem you reported seems to be fixed now.

Actually it should be image/vnd.microsoft.icon according to this:

http://en.wikipedia.org/wiki/Favicon

Though if image/x-icon works everywhere...

comment:5 Changed 10 years ago by diver

Firefox 3.5.2 on linux refused to open http://www.haiku-os.org/favicon.ico until I've cleaned my cache.
However BezillaBrowser still doesn't show favicon.

comment:6 in reply to:  5 Changed 10 years ago by koki

Replying to diver:

However BezillaBrowser still doesn't show favicon.

Added the image/vnd.microsoft.icon MIME type as Ryan suggested. Can you please check again? Thanks!

comment:7 Changed 10 years ago by diver

Sorry, it still doesn't work.

comment:8 Changed 10 years ago by koki

I don't know what else it could be, but let me make two points:

1) The website theme favicon is not located in the root directory (it's in the theme folder).

2) BezillaBrowser does not seem to have any file types configured, so it may be a client-side (rather than a server-side) problem. You may want to try checking with the Bezilla guys.

comment:9 Changed 10 years ago by diver

Just to be clear, BeZillaBrowser don't ask me to save favicon anymore and open it correctly after your .htaccess trick, but still doesn't show favicon in bookmark panel.

Changed 10 years ago by diver

comment:10 Changed 10 years ago by diver

comment:11 in reply to:  9 ; Changed 10 years ago by kwurzel

Replying to diver:

Just to be clear, BeZillaBrowser don't ask me to save favicon anymore and open it correctly after your .htaccess trick, but still doesn't show favicon in bookmark panel.

Not updating the favicon is a common problem with Firefox. Please try if removing the bookmark and "re-bookmarking" the page does work (please clear your cache after removing, just to be clear).

Thank you!

comment:12 in reply to:  4 ; Changed 10 years ago by axeld

Replying to leavengood:

Actually it should be image/vnd.microsoft.icon according to this:

http://en.wikipedia.org/wiki/Favicon

Though if image/x-icon works everywhere...

Just for the record: our ICO translator is using x-icon, only, IIRC. I did not heard about the other form before either.

comment:13 in reply to:  12 Changed 10 years ago by leavengood

Replying to axeld:

Just for the record: our ICO translator is using x-icon, only, IIRC. I did not heard about the other form before either.

The other form does seem to be the "official" one:

http://www.iana.org/assignments/media-types/image/vnd.microsoft.icon

So we should at least add that MIME type to our database and the ICO translator. Leaving x-icon too of course.

comment:14 Changed 10 years ago by axeld

Looks like I already did so in hrev17465 - I'm getting senile :-)

comment:15 in reply to:  11 Changed 10 years ago by diver

Replying to kwurzel:

Not updating the favicon is a common problem with Firefox. Please try if removing the bookmark and "re-bookmarking" the page does work (please clear your cache after removing, just to be clear).

Sure, I've cleaned my cache and "re-bookmarked" it several times, nothing helps.

comment:16 Changed 10 years ago by umccullough

Even if this only happens with haiku-os.org, it really does sound like a BeZillaBrowser issue. Perhaps you should file a ticket over at HaikuPorts?

Once the exact problem is identified by the BeZillaBrowser devs, then we can decide what to fix on our website?

comment:17 Changed 10 years ago by diver

Maybe someone could confirm this issue then? I don't have a login at HaikuPorts and don't see register link enywhere, so I can't create a ticket there.

comment:18 in reply to:  17 ; Changed 10 years ago by koki

Replying to diver:

Maybe someone could confirm this issue then?

I can confirm that BezillaBrowser indeed does not show the favicon in the bookmarks toolbar, but the problem does not seem to be limited to our website. In fact, I tried with several other sites (cnn.com, osnews.com, asahi.com, etc.), and BezillaBrowser failed in everyone of them. Looks like a bug report with the Bezilla folks is in order. :)

With regards to Haiku not being able to open the .ico file, hopefully Axel will take of that some day. :) (/me wonders if a separate bug report is needed for that).

comment:19 in reply to:  18 Changed 10 years ago by leavengood

Replying to koki:

With regards to Haiku not being able to open the .ico file, hopefully Axel will take of that some day. :) (/me wonders if a separate bug report is needed for that).

I don't see any problems like that reported in the above discussion.

I checked the code and we are using the image/vnd.microsoft.icon MIME type at least.

comment:20 Changed 10 years ago by diver

I've tested it in Windows XP with Firefox 2.0.2.0 and it suffers from the same problem. Firefox 3.0.10 don't show this problem.

comment:21 Changed 10 years ago by diver

Feel free to close this ticket now.

comment:22 Changed 10 years ago by nielx

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.