Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4338 closed bug (duplicate)

[Tracker] crash in BWindow::IsHidden ()

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: #4274 Blocking:
Has a Patch: no Platform: All

Description

Launch SoundPlay and drop mp3 file over it.
Drop replicant of SoundPlay to Desktop
Click on the song title in replicant and select "Playlist editor"
Close Playlist editor:

Thread 631 caused an exception: Segment violation
Reading symbols from /boot/system/runtime_loader...done.
Loaded symbols for /boot/system/runtime_loader
Reading symbols from /boot/system/lib/libbe.so...done.
Loaded symbols for /boot/system/lib/libbe.so
Reading symbols from /boot/system/lib/libtracker.so...done.
Loaded symbols for /boot/system/lib/libtracker.so
Reading symbols from /boot/system/lib/libroot.so...done.
Loaded symbols for /boot/system/lib/libroot.so
Reading symbols from /boot/system/lib/libstdc++.r4.so...done.
Loaded symbols for /boot/system/lib/libstdc++.r4.so
Reading symbols from /boot/system/lib/libtranslation.so...done.
Loaded symbols for /boot/system/lib/libtranslation.so
Reading symbols from /boot/system/lib/libtextencoding.so...done.
Loaded symbols for /boot/system/lib/libtextencoding.so
Reading symbols from /boot/system/apps/Workspaces...done.
Loaded symbols for /boot/system/apps/Workspaces
Reading symbols from /boot/system/add-ons/Translators/BMPTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/BMPTranslator
Reading symbols from /boot/system/add-ons/Translators/EXRTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/EXRTranslator
Reading symbols from /boot/system/lib/libilmimf.so...done.
Loaded symbols for /boot/system/lib/libilmimf.so
Reading symbols from /boot/system/lib/libz.so...done.
Loaded symbols for /boot/system/lib/libz.so
Reading symbols from /boot/system/add-ons/Translators/GIFTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/GIFTranslator
Reading symbols from /boot/system/add-ons/Translators/JPEG2000Translator...done.
Loaded symbols for /boot/system/add-ons/Translators/JPEG2000Translator
Reading symbols from /boot/system/add-ons/Translators/JPEGTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/JPEGTranslator
Reading symbols from /boot/system/add-ons/Translators/PCXTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/PCXTranslator
Reading symbols from /boot/system/add-ons/Translators/PNGTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/PNGTranslator
Reading symbols from /boot/system/add-ons/Translators/PPMTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/PPMTranslator
Reading symbols from /boot/system/add-ons/Translators/RAWTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/RAWTranslator
Reading symbols from /boot/system/add-ons/Translators/RTF-Translator...done.
Loaded symbols for /boot/system/add-ons/Translators/RTF-Translator
Reading symbols from /boot/system/add-ons/Translators/SGITranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/SGITranslator
Reading symbols from /boot/system/add-ons/Translators/STXTTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/STXTTranslator
Reading symbols from /boot/system/add-ons/Translators/TGATranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/TGATranslator
Reading symbols from /boot/system/add-ons/Translators/TIFFTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/TIFFTranslator
Reading symbols from /boot/system/add-ons/Translators/WonderBrushTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/WonderBrushTranslator
Reading symbols from /data/apps/SoundPlay/SoundPlay...done.
Loaded symbols for /data/apps/SoundPlay/SoundPlay
Reading symbols from /boot/home/config/lib/liblayout.so...done.
Loaded symbols for /boot/home/config/lib/liblayout.so
Reading symbols from /boot/system/lib/libmedia.so...done.
Loaded symbols for /boot/system/lib/libmedia.so
Reading symbols from /boot/system/lib/libgame.so...done.
Loaded symbols for /boot/system/lib/libgame.so
Reading symbols from /boot/system/lib/libbnetapi.so...done.
Loaded symbols for /boot/system/lib/libbnetapi.so
Reading symbols from /boot/system/lib/libnetwork.so...done.
Loaded symbols for /boot/system/lib/libnetwork.so
Reading symbols from /data/apps/SoundPlay/Plugins/AudioIn...done.
Loaded symbols for /data/apps/SoundPlay/Plugins/AudioIn
Reading symbols from /data/apps/SoundPlay/Plugins/CPlusAdapter...done.
Loaded symbols for /data/apps/SoundPlay/Plugins/CPlusAdapter
Reading symbols from /data/apps/SoundPlay/Plugins/Deskbar...done.
Loaded symbols for /data/apps/SoundPlay/Plugins/Deskbar
Reading symbols from /data/apps/SoundPlay/Plugins/DeskbarFFT...done.
Loaded symbols for /data/apps/SoundPlay/Plugins/DeskbarFFT
Reading symbols from /data/apps/SoundPlay/Plugins/DeskbarVU...done.
Loaded symbols for /data/apps/SoundPlay/Plugins/DeskbarVU
Reading symbols from /data/apps/SoundPlay/Plugins/FreeVerb...done.
Loaded symbols for /data/apps/SoundPlay/Plugins/FreeVerb
Reading symbols from /data/apps/SoundPlay/Plugins/LiveEncoder...done.
Loaded symbols for /data/apps/SoundPlay/Plugins/LiveEncoder
Reading symbols from /data/apps/SoundPlay/Plugins/LoudnessPlugin...done.
Loaded symbols for /data/apps/SoundPlay/Plugins/LoudnessPlugin
Reading symbols from /data/apps/SoundPlay/Plugins/MP3Clean...done.
Loaded symbols for /data/apps/SoundPlay/Plugins/MP3Clean
Reading symbols from /data/apps/SoundPlay/Plugins/MidiRenderer...done.
Loaded symbols for /data/apps/SoundPlay/Plugins/MidiRenderer
Reading symbols from /data/apps/SoundPlay/Plugins/ModPlugin...done.
Loaded symbols for /data/apps/SoundPlay/Plugins/ModPlugin
Reading symbols from /data/apps/SoundPlay/Plugins/NoVoicePlugin...done.
Loaded symbols for /data/apps/SoundPlay/Plugins/NoVoicePlugin
Reading symbols from /data/apps/SoundPlay/Plugins/Noise...done.
Loaded symbols for /data/apps/SoundPlay/Plugins/Noise
Reading symbols from /data/apps/SoundPlay/Plugins/OggVorbis...done.
Loaded symbols for /data/apps/SoundPlay/Plugins/OggVorbis
Reading symbols from /boot/home/config/lib/libogg.so...done.
Loaded symbols for /boot/home/config/lib/libogg.so
Reading symbols from /boot/home/config/lib/libvorbisfile.so...done.
Loaded symbols for /boot/home/config/lib/libvorbisfile.so
Reading symbols from /boot/home/config/lib/libvorbis.so...done.
Loaded symbols for /boot/home/config/lib/libvorbis.so
Reading symbols from /data/apps/SoundPlay/Plugins/PitchChange...done.
Loaded symbols for /data/apps/SoundPlay/Plugins/PitchChange
Reading symbols from /data/apps/SoundPlay/Plugins/SimpleScopePlugin...done.
Loaded symbols for /data/apps/SoundPlay/Plugins/SimpleScopePlugin
Reading symbols from /data/apps/SoundPlay/Plugins/SpectrumAnalyzer...done.
Loaded symbols for /data/apps/SoundPlay/Plugins/SpectrumAnalyzer
Loaded symbols for /data/apps/SoundPlay/SoundPlay
Loaded symbols for /data/apps/SoundPlay/Plugins/AudioIn
Loaded symbols for /data/apps/SoundPlay/Plugins/CPlusAdapter
Loaded symbols for /data/apps/SoundPlay/Plugins/Deskbar
Loaded symbols for /data/apps/SoundPlay/Plugins/DeskbarFFT
Loaded symbols for /data/apps/SoundPlay/Plugins/DeskbarVU
Loaded symbols for /data/apps/SoundPlay/Plugins/FreeVerb
Loaded symbols for /data/apps/SoundPlay/Plugins/LiveEncoder
Loaded symbols for /data/apps/SoundPlay/Plugins/LoudnessPlugin
Loaded symbols for /data/apps/SoundPlay/Plugins/MP3Clean
Loaded symbols for /data/apps/SoundPlay/Plugins/MidiRenderer
Loaded symbols for /data/apps/SoundPlay/Plugins/ModPlugin
Loaded symbols for /data/apps/SoundPlay/Plugins/NoVoicePlugin
Loaded symbols for /data/apps/SoundPlay/Plugins/Noise
Loaded symbols for /data/apps/SoundPlay/Plugins/OggVorbis
Loaded symbols for /data/apps/SoundPlay/Plugins/PitchChange
Loaded symbols for /data/apps/SoundPlay/Plugins/SimpleScopePlugin
Loaded symbols for /data/apps/SoundPlay/Plugins/SpectrumAnalyzer
Loaded symbols for /data/apps/SoundPlay/SoundPlay
Loaded symbols for /data/apps/SoundPlay/SoundPlay
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/system/Tracker (84) thread w>SoundPlay playlist editor (631)]
0x003880be in BWindow::IsHidden () from /boot/system/lib/libbe.so
(gdb) bt
#0  0x003880be in BWindow::IsHidden () from /boot/system/lib/libbe.so
#1  0x00386d40 in BWindow::IsMinimized () from /boot/system/lib/libbe.so
#2  0x08c418aa in SoundPlayController::IsMainInterfaceHidden ()
   from /data/apps/SoundPlay/SoundPlay
#3  0x08c48d58 in aa_zzzzzzzzzzzzzzzzzzzz ()
   from /data/apps/SoundPlay/SoundPlay
#4  0x002c57f2 in BLooper::Quit () from /boot/system/lib/libbe.so
#5  0x00382a7a in BWindow::Quit () from /boot/system/lib/libbe.so
#6  0x002c6e7b in BLooper::_QuitRequested () from /boot/system/lib/libbe.so
#7  0x002c5376 in BLooper::DispatchMessage () from /boot/system/lib/libbe.so
#8  0x00385749 in BWindow::DispatchMessage () from /boot/system/lib/libbe.so
#9  0x003894ac in BWindow::task_looper () from /boot/system/lib/libbe.so
#10 0x002c68e7 in BLooper::_task0_ () from /boot/system/lib/libbe.so
#11 0x0069f124 in thread_entry () from /boot/system/lib/libroot.so
#12 0x783cdfec in ?? ()
(gdb) 

Tested with hrev32651 in VirtualBox 3.0.4.

Change History (2)

comment:1 by anevilyak, 10 years ago

Blocked By: 4274 added
Resolution: duplicate
Status: newclosed

Duplicate of #4274.

comment:2 by diver, 10 years ago

Oops, sorry.

Note: See TracTickets for help on using tickets.