Opened 10 years ago

Closed 10 years ago

#4340 closed bug (fixed)

nVidia HDA chipset seen, but no sound

Reported by: Luposian Owned by: korli
Priority: normal Milestone: R1
Component: Drivers/Audio/HDA Version: R1/pre-alpha1
Keywords: Cc: haiku@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

On my Asus motherboard, the HDA driver is loaded and the chipset is seen, but I can't get a peep out of the audio, no matter what I do.

I'm including a SysLog for diagnostic purposes.

Attachments (5)

syslog (139.1 KB ) - added by Luposian 10 years ago.
syslog.txt (84.4 KB ) - added by VinDuv 10 years ago.
syslog.2 (102.8 KB ) - added by plfiorini 10 years ago.
syslog for MCP51 (Haiku hrev32950)
syslog2.txt (255.0 KB ) - added by VinDuv 10 years ago.
Syslog for hrev32971
syslog.2.txt (87.3 KB ) - added by VinDuv 10 years ago.
Syslog for hrev34753

Download all attachments as: .zip

Change History (25)

by Luposian, 10 years ago

Attachment: syslog added

comment:1 by plfiorini, 10 years ago

I confirm this bug too: MediaPlayer doesn't even advance its progress bar. Unfortunately I booted with OSS so I can't get a syslog unless I reinstall Haiku since I removed the hda driver.

Here's ossinfo output about my audio chipset:

    HD Audio controller nVidia HD Audio
    Vendor ID    0x10de026c
    Subvendor ID 0x147b1c26
     Codec  0: ALC883 (0x10ec0883/0x147b8e01)

comment:2 by plfiorini, 10 years ago

I now realized that this information might be only related to OSS. Here's what listdev says about my HDA chipset:

device Multimedia controller (Audio device) [4|3|0]
  vendor 10de: nVidia Corporation
  device 026c: MCP51 High Definition Audio

comment:3 by korli, 10 years ago

Owner: changed from axeld to korli

The weird thing is I have the very same codec but on an Intel chip.

in reply to:  3 ; comment:4 by plfiorini, 10 years ago

Replying to korli:

The weird thing is I have the very same codec but on an Intel chip.

Please, don't tell me - I was even happy buying this motherboard :)

in reply to:  4 ; comment:5 by korli, 10 years ago

Replying to plfiorini:

Please, don't tell me - I was even happy buying this motherboard :)

Could you test several changes in the hda driver, if you build it from source ? in hda_multi_audio.cpp, change the #if 0 to #if 1 before the line: static int debug_buffers_exchanged = 0; in hda_controller.cpp, try to comment out the lines 784 to 787. Thanks

in reply to:  5 ; comment:6 by mmadia, 10 years ago

Replying to korli:

Could you test several changes in the hda driver, if you build it from source ? in hda_multi_audio.cpp, change the #if 0 to #if 1 before the line: static int debug_buffers_exchanged = 0; in hda_controller.cpp, try to comment out the lines 784 to 787. Thanks

Im not sure which lines you're referring to in hda_controller.cpp, as 784 seems to be a multi line statement http://dev.haiku-os.org/browser/haiku/trunk/src/add-ons/kernel/drivers/audio/hda/hda_controller.cpp

in reply to:  6 comment:7 by korli, 10 years ago

Replying to mmadia:

Replying to korli:

Could you test several changes in the hda driver, if you build it from source ? in hda_multi_audio.cpp, change the #if 0 to #if 1 before the line: static int debug_buffers_exchanged = 0; in hda_controller.cpp, try to comment out the lines 784 to 787. Thanks

Im not sure which lines you're referring to in hda_controller.cpp, as 784 seems to be a multi line statement http://dev.haiku-os.org/browser/haiku/trunk/src/add-ons/kernel/drivers/audio/hda/hda_controller.cpp

sorry I was using an old version. I meant the lines with NVIDIA_HDA_ISTRM_COH and NVIDIA_HDA_OSTRM_COH

comment:8 by VinDuv, 10 years ago

I have the same problem (no sound, stuck MediaPlayer) with a similar HDA chipset :

device Multimedia controller (Audio device) [4|3|0]
  vendor 10de: nVidia Corporation
  device 0ac0: MCP79 High Definition Audio

Unfortunately, the suggested patch did not have any effect.
Syslog attached.

by VinDuv, 10 years ago

Attachment: syslog.txt added

by plfiorini, 10 years ago

Attachment: syslog.2 added

syslog for MCP51 (Haiku hrev32950)

comment:9 by plfiorini, 10 years ago

I removed that 4 lines, but still got the same issue. Syslog is attached.

comment:10 by korli, 10 years ago

VinDuv, could you try with hrev32971 ? It seems your codec exposed float format support and the addon picked it up.

in reply to:  10 comment:11 by VinDuv, 10 years ago

Replying to korli:

VinDuv, could you try with hrev32971 ? It seems your codec exposed float format support and the addon picked it up.

Unfortunately, still no sound :-(

New syslog attached.

by VinDuv, 10 years ago

Attachment: syslog2.txt added

Syslog for hrev32971

comment:12 by scottmc, 10 years ago

Cc: haiku@… added

comment:13 by aljen, 10 years ago

Same here, chip detected, I can see it in media prefs but no sound at all.
listdev output:

device Multimedia controller (Audio device) [4|3|0]
  vendor 8086: Intel Corporation
  device 27d8: 82801G (ICH7 Family) High Definition Audio Controller

in reply to:  13 comment:14 by korli, 10 years ago

Replying to aljen:

Same here, chip detected, I can see it in media prefs but no sound at all.
listdev output:

device Multimedia controller (Audio device) [4|3|0]
  vendor 8086: Intel Corporation
  device 27d8: 82801G (ICH7 Family) High Definition Audio Controller

aljen, could you file another bug report because this one isn't related to intel chips ? Thanks

comment:15 by Luposian, 10 years ago

Just discovered that the OSS driver (located at HaikuWare) works with my nVidia MCP51 chipset. I disabled Haiku's HDA driver and the OSS driver worked. Had to configure things a tad, but got playback, finally! .MP3's seem to play fine. But it can't play .wav's, for some reason.

Is it possible to somehow incorporate/enable OSS in Haiku, so a seperate download/install isn't necessary?

Dunno if this ends/closes this bug report or not, will let someone else decide that. As Haiku still does not natively support the MCP51 chipset, maybe it should still stay open?

comment:16 by Luposian, 10 years ago

AUSA!!! Audio now works! And I don't think it's using OSS (which I think is also an installed/installable driver in Haiku?), because when I would install OSS, .WAV's wouldn't play right (they were all choppy and stuttering), while .MP3's would play fine. Now, both .MP3's and .WAV's play perfectly!

Also, an obvious indicator (at least for me) to whether or not Haiku's audio was working right was how long it took to shut down the media stuff... if it shuts it all down quickly, audio works (or the driver is disabled) and if it takes a couple seconds for it to shut it all down, audio does NOT work.

Well, Haiku now shuts down immediately!

Consider this ticket... C-L-O-S-E-D !!!

Thank you so very much, guys!

comment:17 by stippi, 10 years ago

Resolution: fixed
Status: newclosed

Cool, thanks for the feedback. #4398 might be a duplicate of this one.

comment:18 by VinDuv, 10 years ago

Resolution: fixed
Status: closedreopened

Unfortunately in my case I still don't get any sound. MediaPlayer works correctly now, though. This is hrev34753.

by VinDuv, 10 years ago

Attachment: syslog.2.txt added

Syslog for hrev34753

comment:19 by Luposian, 10 years ago

Dude... VinDuv... youz b rainin' on my parade! Hogging my ticket for your own nefarious purposes! :-D

My problem is fixed... unless you have the EXACT same chipset (which you don't; an MCP79 is not an MCP51... it's 28 digits higher/newer), I think this particular ticket should be closed... unless plfiorini (who, I believe, has the same chipset I do) is still having problems.

What say ye, Stippi or Korli?

comment:20 by scottmc, 10 years ago

Resolution: fixed
Status: reopenedclosed

yeah VinDuv, the original issue as reported was fixed, they also fixed the HDA ticket I opened. Please open a new ticket and post the listdev entry for your chipset in the ticket summary, and attach your syslog there. closing this one as fixed.

Note: See TracTickets for help on using tickets.