Opened 10 years ago

Closed 10 years ago

#4353 closed bug (duplicate)

'common' folder appears as text-file type

Reported by: Pete Owned by: bonefish
Priority: normal Milestone: R1
Component: Build System Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

In the distributed raw image hrev32645, '/boot/common' shows up as a text file (although the contents are available when clicked).

Within the folder, 'bin' also appears with a text icon.

Change History (8)

comment:1 Changed 10 years ago by mmlr

Component: - GeneralBuild System
Owner: changed from axeld to bonefish

comment:2 Changed 10 years ago by axeld

This is something I also often get when I don't use xattr support, and build on Linux. It could be that it only happens with -j2 (or higher), but I'm not sure about it.

comment:3 Changed 10 years ago by phoudoin

I get the same, and never build on Linux using the -j option. Should be related to xattr, then. I don't use either. Well, AFAICT :-).

comment:4 Changed 10 years ago by scottmc

Could this be caused by one or more of the OptionalPackages? Or perhaps when the ssh keys are made? Just a thought.

comment:5 in reply to:  4 Changed 10 years ago by bonefish

Replying to scottmc:

Could this be caused by one or more of the OptionalPackages? Or perhaps when the ssh keys are made? Just a thought.

I have never seen this. Since I only build with xattr support, I'm pretty sure it's indeed related to using the no-xattr attribute emulation. Since this method is officially discouraged, I'm lowering the ticket priority. Moreover I'm urging Sikosis to adjust the build factory -- official builds must not use the no-xattr attribute emulation.

comment:6 Changed 10 years ago by anevilyak

Interestingly I just saw this problem here as well, and I am using xattr. The only folder I've noticed it for though is one that's unzipped from a downloaded package rather than generated in the buildsys, which definitely didn't have that problem in the past (the zip hasn't changed in months).

comment:7 Changed 10 years ago by anevilyak

Scratch that, sorry for the noise. Somehow HAIKU_HOST_USE_XATTR was disabled in my BuildConfig, probably an accident when reconfiguring updated build tools.

comment:8 Changed 10 years ago by mmadia

Resolution: duplicate
Status: newclosed

The build factory at the time did not use xattr support. Duplicate of #3910

Note: See TracTickets for help on using tickets.