Opened 10 years ago

Closed 9 years ago

#4357 closed bug (fixed)

[LiveCD] mmu_free: unmap out of range

Reported by: Disreali Owned by: axeld
Priority: normal Milestone: R1
Component: System/Boot Loader Version: R1/alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I attempted to boot alpha-candidate hrev32746 CD on an ACER M5620 and received the following error:

***PANIC***

mmu_free: asked to unmap out of range region (0x8021000, size 1000)

I burnt the iso to cd with ImgBurn using single speed. I was able to get more info by hitting <esc> twice very fast as the cd started to spin up. Photo attached.

Hardware info:

System Information
----------------------
System Name	Aspire M5620
Mainboard Vendor	ACER
Mainboard Model	G33T-AM
BIOS Vendor	American Megatrends Inc.

Processor 1 (ID = 0)
Number of cores		4 (max 4)
Number of threads	4 (max 4)
Name			Intel Core 2 Quad Q6600
Codename		Kentsfield
Specification		Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz

Chipset

Northbridge		Intel P35/G33/G31 rev. A2
Southbridge		Intel 82801IR (ICH9R) rev. 02
Graphic Interface	PCI-Express
PCI-E Link Width	x16
PCI-E Max Link Width	x16
Memory Type		DDR2
Memory Size		3072 MBytes

Attachments (7)

haiku-cd_error.jpg (208.8 KB) - added by Disreali 10 years ago.
14floppy.diff (802 bytes) - added by ArCePi 10 years ago.
Creates a 1440 kB floppy image.
1.44MB_boot_cd_error.jpg (231.5 KB) - added by Disreali 10 years ago.
2.8MB_bootcd_error.jpg (214.2 KB) - added by Disreali 10 years ago.
acer-am5620_lsdev.txt (1.8 KB) - added by Disreali 10 years ago.
acer-am5620_lspci.txt (2.0 KB) - added by Disreali 10 years ago.
acer-am5620_lsusb.txt (858 bytes) - added by Disreali 10 years ago.

Download all attachments as: .zip

Change History (16)

Changed 10 years ago by Disreali

Attachment: haiku-cd_error.jpg added

comment:1 Changed 10 years ago by mmlr

Component: - GeneralSystem/Boot Loader

comment:2 Changed 10 years ago by ArCePi

I have the same problem on a Compaq Armada 1750.

In my trace, it doesn't print any error related to read errors and the memory address is different:

mmu_free: asked to unmap out of range region (0x8020f000, size 1000)

Specs are:

  • Mobile Pentium II 333 MHz
  • 186 MB RAM
  • Chipset: Intel 440BX/DX

comment:3 Changed 10 years ago by ArCePi

I've compiled a haiku-boot-floppy enabling TRACE in the elf loader and in tarfs. I've also added debug output in Partitions::ReadAt() that prints the partition size and the position from where it is asked to read.

In my laptop partition size is reported as 1474560 (or 1440 kB). So I suppose that the problem is that the BIOS is emulating a 1'4 MB floppy instead of a 2'8 one. Tarfs tries reading past that (that's normal) and fails as soon as it goes beyond the reported size.

I've a very small iso image with that debug enabled (booting on a normal computer will result in a crash just at the splash screen, as it only contains the haiku-boot-floppy and nothing else). It is at http://arcepi.net/~arcepi/iso.iso

comment:4 Changed 10 years ago by ArCePi

I've reduced the floppy-boot-image to fit in a 1'4 MB disk by removing the USB modules (path attached).

There's also a new iso image using that floppy. http://arcepi.net/~arcepi/iso14.iso

Disreali: could you try them and see if your laptop was suffering the same problem?

Changed 10 years ago by ArCePi

Attachment: 14floppy.diff added

Creates a 1440 kB floppy image.

comment:5 Changed 10 years ago by Disreali

Summary: Alpha-CD boot errorR1A1 LiveCD boot error

I burned both iso's to CD and booted each one, but got same error.

Changed 10 years ago by Disreali

Attachment: 1.44MB_boot_cd_error.jpg added

Changed 10 years ago by Disreali

Attachment: 2.8MB_bootcd_error.jpg added

Changed 10 years ago by Disreali

Attachment: acer-am5620_lsdev.txt added

Changed 10 years ago by Disreali

Attachment: acer-am5620_lspci.txt added

Changed 10 years ago by Disreali

Attachment: acer-am5620_lsusb.txt added

comment:6 Changed 10 years ago by Disreali

Added output of lsusb, lspci, and lsdev to ticket.

comment:7 Changed 10 years ago by Disreali

Summary: R1A1 LiveCD boot error[LiveCD] mmu_free: unmap out of range
Version: R1/pre-alpha1R1/alpha1

Still get same panic error with hrev33300 livecd and usb stick. Unable to get to boot options.

comment:8 Changed 9 years ago by Disreali

I just tested hrev35981 with both LiveCD and USB and haiku was able to boot on my hardware just fine. Not sure if anyone else is still having this issue, but it is fixed for me.

comment:9 Changed 9 years ago by bonefish

Resolution: fixed
Status: newclosed

Thanks for the update.

Note: See TracTickets for help on using tickets.