Opened 9 years ago

Closed 4 months ago

Last modified 4 months ago

#4376 closed bug (not reproducible)

Haiku does not boot with ehci in image and Legacy support enabled in bios

Reported by: PieterPanman Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB/EHCI Version: R1/Development
Keywords: Cc: maxim.sokhatsky@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Haiku does not boot on hrev32819. Removing ehci from the driver allows it to boot fine. This has been so for a long time (maybe a year?). Removing the firewire, while leaving the ehci in the image it still does not boot. Will attach relevant camera pictures and lspci from linux.

Attachments (11)

lspci.txt (17.3 KB) - added by PieterPanman 9 years ago.
lspci -vv on fedora 11
ehci_freezes_1.JPG (288.1 KB) - added by PieterPanman 9 years ago.
ehci_freezes_2.JPG (262.6 KB) - added by PieterPanman 9 years ago.
ehci_freezes_3.JPG (268.3 KB) - added by PieterPanman 9 years ago.
ehci_freezes_4.JPG (252.5 KB) - added by PieterPanman 9 years ago.
ehci_freezes_5.JPG (252.2 KB) - added by PieterPanman 9 years ago.
ehci_freezes_6.JPG (257.6 KB) - added by PieterPanman 9 years ago.
listdev.txt (4.0 KB) - added by PieterPanman 9 years ago.
listdev-d.txt (16.6 KB) - added by PieterPanman 9 years ago.
syslog (91.5 KB) - added by PieterPanman 9 years ago.
syslog_usb_legacy_disabled (91.9 KB) - added by PieterPanman 9 years ago.
Succesful start with ehci in the image

Download all attachments as: .zip

Change History (25)

Changed 9 years ago by PieterPanman

Attachment: lspci.txt added

lspci -vv on fedora 11

comment:1 Changed 9 years ago by PieterPanman

Also removing the usb_webcam driver doesn't help.

Changed 9 years ago by PieterPanman

Attachment: ehci_freezes_1.JPG added

Changed 9 years ago by PieterPanman

Attachment: ehci_freezes_2.JPG added

Changed 9 years ago by PieterPanman

Attachment: ehci_freezes_3.JPG added

Changed 9 years ago by PieterPanman

Attachment: ehci_freezes_4.JPG added

Changed 9 years ago by PieterPanman

Attachment: ehci_freezes_5.JPG added

Changed 9 years ago by PieterPanman

Attachment: ehci_freezes_6.JPG added

comment:2 Changed 9 years ago by mmlr

Component: - GeneralDrivers/USB
Owner: changed from axeld to mmlr
Status: newassigned

Do you have any BIOS options you could try to modify regarding USB? Legacy support would be the most interesting.

comment:3 Changed 9 years ago by PieterPanman

Yup, I do have the legacy support option, will try it. I just created a build without EHCI, boots fine, will attach the fresh syslog in a minute.

Changed 9 years ago by PieterPanman

Attachment: listdev.txt added

Changed 9 years ago by PieterPanman

Attachment: listdev-d.txt added

Changed 9 years ago by PieterPanman

Attachment: syslog added

comment:4 Changed 9 years ago by PieterPanman

Huh. It was set to legacy support when it failed to boot. Turning off legacy support fixes the problem, it boots fine again. So all the files above are with legacy support enabled. Below I'll attach the syslog of the successful boot.

Changed 9 years ago by PieterPanman

Attachment: syslog_usb_legacy_disabled added

Succesful start with ehci in the image

comment:5 Changed 9 years ago by PieterPanman

Summary: Haiku does not boot with ehci in imageHaiku does not boot with ehci in image and Legacy support enabled in bios

Thanks for the pointers, it makes trying out Haiku much easier. I suppose the cause for this should be found though... Maybe it is specific to my laptop, not sure. Let me know if I can help with more debugging output, I can build my own images.

comment:6 Changed 9 years ago by PieterPanman

I no longer have this laptop, but this might still be relevant. Close or not?

comment:7 Changed 9 years ago by mmlr

Resolution: fixed
Status: in-progressclosed

Since this can't be reproduced anymore (due to the hardware not being around anymore) I'm closing this one. Quite likely it was the same issue as the last one of the ones in #2083 and therefore fixed by hrev35780.

comment:8 Changed 8 years ago by 5HT

Cc: maxim.sokhatsky@… added
Resolution: fixed
Status: closedreopened
Version: R1/pre-alpha1R1/Development

Exectly the same issue on SONY VAIO SZ. hrev37966.

comment:9 Changed 7 years ago by scottmc

Can you recheck this with a recent Haiku build? It may have been fixed recently.

comment:10 Changed 7 years ago by scottmc

Blocking: 7665 added

comment:11 Changed 7 years ago by PieterPanman

I still don't have this laptop anymore, can't test it. Maybe 5HT still can. Thanks for checking up.

comment:12 Changed 4 years ago by waddlesplash

Component: Drivers/USBDrivers/USB/EHCI

Sorting out Drivers/USB/EHCI tickets from Drivers/USB.

comment:13 Changed 4 months ago by waddlesplash

Resolution: not reproducible
Status: reopenedclosed

comment:14 Changed 4 months ago by waddlesplash

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.