Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4395 closed bug (fixed)

Build failure in KPartition

Reported by: andreasf Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

C++ /home/andreas/Haiku/haiku/generated-gcc4.3/objects/haiku/x86/release/system/kernel/disk_device_manager/KPartition.o 
/home/andreas/Haiku/haiku/src/system/kernel/disk_device_manager/KPartition.cpp:52: error: 'int32 BPrivate::DiskDevice::KPartition::sNextID' is not a static member of 'class BPrivate::DiskDevice::KPartition'
/home/andreas/Haiku/haiku/src/system/kernel/disk_device_manager/KPartition.cpp: In static member function 'static int32 BPrivate::DiskDevice::KPartition::_NextID()':
/home/andreas/Haiku/haiku/src/system/kernel/disk_device_manager/KPartition.cpp:1583: error: 'sNextID' was not declared in this scope

This is at hrev32891, using GCC 4.

Change History (9)

comment:1 Changed 10 years ago by anevilyak

Resolution: fixed
Status: newclosed

Fixed by stippi in hrev32893.

comment:2 Changed 10 years ago by axeld

And for the future, please don't use the bug tracker to report build problems.

comment:3 in reply to:  2 Changed 10 years ago by koki

Replying to axeld:

And for the future, please don't use the bug tracker to report build problems.

The problem is that our Development FAQ page here...

http://www.haiku-os.org/development/faq#build-fails

...specifically points people with build problems to report them to Trac. I have changed the website FAQ for consistency.

comment:4 Changed 10 years ago by axeld

I didn't know that, thanks for changing it, Jorge!

comment:5 in reply to:  2 Changed 10 years ago by andreasf

Replying to axeld:

And for the future, please don't use the bug tracker to report build problems.

Thanks for the friendly notice. When you've reported some dozen issues on Trac you don't re-read FAQs all too often and haiku-development is no longer an option for occasional reading, sorry.

comment:6 Changed 10 years ago by bonefish

I think it would be a good idea to have a B-O-M status page. The FAQ and the Trac main page could link there and recommend to only report build problems that have not been noticed by B-O-M. Matt, you listening? :-)

comment:7 in reply to:  6 ; Changed 10 years ago by mmadia

Replying to bonefish:

I think it would be a good idea to have a B-O-M status page. The FAQ and the Trac main page could link there and recommend to only report build problems that have not been noticed by B-O-M. Matt, you listening? :-)

the thought has crossed my mind a few times. it is on my todo list -- just the whole dime and ability thing comes into play.

comment:8 in reply to:  7 Changed 10 years ago by bonefish

Replying to mmadia:

Replying to bonefish:

I think it would be a good idea to have a B-O-M status page. The FAQ and the Trac main page could link there and recommend to only report build problems that have not been noticed by B-O-M. Matt, you listening? :-)

the thought has crossed my mind a few times. it is on my todo list -- just the whole dime and ability thing comes into play.

I suppose "dime" == "time" (not "money" :-)). I completely understand that. I was only thinking of generating a stylable HTML or XML version of the info sent by mail already and uploading it someplace. Maybe someone knowledgeable in that area can propose a template how that data needs to be formatted to make it look all nice.

comment:9 Changed 10 years ago by andreasf

What about having the notice on the New Ticket page, close to the submit button? (not knowing what B-O-M refers to)

Note: See TracTickets for help on using tickets.