Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4411 closed bug (fixed)

7600go, only 16(?) bit depth

Reported by: humdinger Owned by: rudolfc
Priority: normal Milestone: R1
Component: Drivers/Graphics/nVidia Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is pre-alpha hrev32931.

Hey Rudolf, we're not there yet... :)
I just realized that while Screen says I'm running 32bit, it obviously isn't as I've seen when applying a gradient background. Color bands galore...

I've attached a current log if that helps.

Attachments (4)

nvidia.10de_0398_010000.0.log (80.9 KB) - added by humdinger 10 years ago.
screenshot32.png (26.8 KB) - added by humdinger 10 years ago.
the screenshot taken in 32bit video mode
screenshot16.png (90.5 KB) - added by humdinger 10 years ago.
A screenshot when in 16bit video mode. This is how the 32bit screen looks under Haiku (VESA and with nvidia)
nvidia+syslog.zip (62.9 KB) - added by humdinger 10 years ago.
nvidia log + syslog with attached secondary monitor

Download all attachments as: .zip

Change History (22)

Changed 10 years ago by humdinger

comment:1 Changed 10 years ago by rudolfc

Hi again..

Can you check the laptop specifications please? There are a lot of LCD screens outthere that have only 18bit of colordepth... So: while the driver may set for 32bit, only the upper 18 bit (so to speak) are actually outputted on the screen.

Also: can you check against using 32bit VESA mode? How does it look now?

Bye!

Rudolf.

comment:2 Changed 10 years ago by humdinger

I'm not sure how/where to check the laptop specifics...
I do know, that Ubuntu has no problems displaying the screenshot I made without color bands.

I've zipped up and deleted the nvidia driver and restarted in VESA mode. Screen preferences only offers 1440x1050 in 16bit (native is 1650x1080). Even when changing to a lower resolution that provides 32bit, the color bands remain, suggesting that it's still 16bit.

Also, lowering resolution when using the nvidia driver doesn't change the color bands / depth.

comment:3 Changed 10 years ago by rudolfc

Hi,

Can you upload a screenshot so I can see the distortion?

And: do I understand correctly that you Select a 32bit mode with the screen preflet using VESA mode (you cannot select refreshrates in the preflet, that's your VESA confirmation so to speak), and you still get those colorbands?

Thanks.

Rudolf.

comment:4 Changed 10 years ago by humdinger

You don't see a distortion. I do have a screenshot, but when I look at it in Ubuntu, it's of course a nice pristine 32bit gradiented shot.

And: do I understand correctly that you Select a 32bit mode with the screen preflet using VESA mode (you cannot select refreshrates in the preflet, that's your VESA confirmation so to speak), and you still get those colorbands?

Yes.

Changed 10 years ago by humdinger

Attachment: screenshot32.png added

the screenshot taken in 32bit video mode

Changed 10 years ago by humdinger

Attachment: screenshot16.png added

A screenshot when in 16bit video mode. This is how the 32bit screen looks under Haiku (VESA and with nvidia)

comment:5 Changed 10 years ago by rudolfc

Hi again,

Thanks. Those screenshots are very handy. I'll take a look to see what I can find.

Bye!

Rudolf.

comment:6 Changed 10 years ago by rudolfc

Hi humdinger,

Can you test the 8, 15, and 16 bit modes on Haiku?

You can use the 'appearance' preflet to see if it works OK: 8 bit mode is obvious (different colored boxes); the diff between 15 and 16 bit mode should be visible in the green horizontal line only: in 16 bit mode the extra bit sits here and should make green a bit more smooth than in 15 bit mode. I can see it clearly with my eyes.

32 bit mode: does it look like 15 bit, or 16 bit mode btw? (use appearance: notice the green line)

Thanks!

Rudolf.

comment:7 Changed 10 years ago by rudolfc

Oh,

If you startup in 32bit mode: you have 16 (or 15 bit) color, correct? What happens if you switch to another depth, hit apply, and then reselect 32bit color again?

32bit mode now OK?

  • What happens if you, while having hit apply on32bit color, reboot? 32bit OK? (now a vesa call is made for 32bit before the driver kicks in: that might have influence..)

Thanks!

Rudolf.

comment:8 Changed 10 years ago by rudolfc

Hi again,

Forget about the test above, I can reproduce the effect you've seen. It's indeed a 18bit panel you have, just like I do in my laptop. You can see with appearance that 32bit setting is smoother than 16 bit, still you can recognize the 'steps'.

The picture you uploaded demonstrates the effect much stronger than that. I'll dig into it asap: the nvidia hardware has a component which can mask this effect largely. I did not yet enable this component (can't remember the name atm).

The fact remains that our laptops have 18 bit colordepth panels.

Bye!

Rudolf.

comment:9 Changed 10 years ago by humdinger

Hi Rudolf, sorry for the late reply, I've been on a trip.

A 18bit-panel?! I didn't even know there are panels that limit the displayed bitdepth. I feel a bit cheated by the seller of my notebook. Shouldn't these things be pointed out in the brochure? Pfftt. Anyway...

Thanks for investigating. I hope you'll find that optimizing switch. No hurry though, I'm quite happy having the native resolution now.

comment:10 Changed 10 years ago by rudolfc

Hi again Humdinger,

I am working on implementing dithering support. Over here it's working and the problem is indeed gone then (no more bands of colors).

Maybe I can finish it tomorrow and upload it to svn.

GReetings!

Rudolf.

comment:11 Changed 10 years ago by rudolfc

Hi there,

Please test hrev33653. Dithering is working perfectly over here..

Bye!

Rudolf.

comment:12 Changed 10 years ago by humdinger

Fantastic! No more colour bands[[BR]] Thanks a million, Rudolf!

comment:13 Changed 10 years ago by rudolfc

Cool!

Before I close this ticket, I'm going to connect a second monitor to my laptop at home to see if it's still OK then. If it's not I'll probably add some more code and I might ask you to retest.

BTW: Can you do the same? Please connect a monitor to the external video output of your laptop and determine if the panel still has no colorbands (after a fresh boot).

The second monitor will remain off is all is right, but it influences the signal routing inside the gfx hardware possibly, by just being connected.

Please let me know the results of this test (I'll do the same test here).

Bye!

Rudolf.

comment:14 Changed 10 years ago by humdinger

OK. So I connect my CRT and boot up. I see the BIOS POST and Haiku's booticons on both displays, but when the system comes up, the CRT goes blank.

Good: I don't see any colour bands, even after a reboot.

Bad: The notebook panel now has a max. resolution of 1400x1050x32, there's no option for the native 1680x1050x32 any more.

Thanks!

comment:15 Changed 10 years ago by rudolfc

Hi again humdinger,

Thanks for testing. Could you upload a log from that boot? I'd like to verify where the panel is connected to..

The lower max. resolution came from the fact that the second monitor is taken into account: that one can't handle above 1400x1050 (native) apparantly.

Bye!

Rudolf.

comment:16 Changed 10 years ago by humdinger

nvidia+syslog attached.

It's an old 4:3 CRT monitor, so you're probably right that it doesn't handle the 1680x1050 resolution. :)

Thanks!

Changed 10 years ago by humdinger

Attachment: nvidia+syslog.zip added

nvidia log + syslog with attached secondary monitor

comment:17 Changed 10 years ago by rudolfc

Resolution: fixed
Status: newclosed

Hi again,

Thanks for the log. It indeed shows your panel staying at CRTC1/DAC1, just like mine does, if a secondary screen is attached.

I'm closing this ticket as the colorbands error is fixed. Thanks for your help!

Rudolf.

comment:18 Changed 10 years ago by humdinger

Thanks for your hard work. I'm a very happy camper!

Note: See TracTickets for help on using tickets.