Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#4415 closed enhancement (fixed)

Improve layout of dialogs

Reported by: humdinger Owned by: julun
Priority: normal Milestone: R1
Component: Applications/DriveSetup Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev32931.

The dialogs of DriveSetup could be visually improved. See attached shots.

Create:

  • There's no need for the bordered box around the items.
  • After Partition Size/Name/Type should be a colon.
  • Remove Partition Name if it's not settable. Or align the textboxes of Name and Type if it's to be implemented.

Initialize:

  • After Name/Blocksize should be a colon.
  • The window shouldn't be resizable.
  • There's too much vertical grey space above the first item.

Attachments (2)

drivesetup-create.png (9.3 KB) - added by humdinger 10 years ago.
Create dialog
drivesetup-initialize.png (5.6 KB) - added by humdinger 10 years ago.
Initialize dialog

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by humdinger

Attachment: drivesetup-create.png added

Create dialog

Changed 10 years ago by humdinger

Attachment: drivesetup-initialize.png added

Initialize dialog

comment:1 Changed 9 years ago by julun

Owner: changed from stippi to julun
Status: newin-progress

comment:2 Changed 9 years ago by julun

Resolution: fixed
Status: in-progressclosed

Fixed in 35120.

comment:3 Changed 9 years ago by humdinger

Thanks julun! If I may nitpick: In the "Initialize" dialog the offset of the controls to the window borders and each other is a bit large compared with e.g. the "Create" dialog. Should you change that, could you add a ":" to "Name" and "Blocksize"?

comment:4 in reply to:  3 Changed 9 years ago by julun

Resolution: fixed
Status: closedreopened

Replying to humdinger:

Thanks julun! If I may nitpick: In the "Initialize" dialog the offset of the controls to the window borders and each other is a bit large compared with e.g. the "Create" dialog. Should you change that, could you add a ":" to "Name" and "Blocksize"?


Hi, looking at my patch I thought I had changed that. See for example the first few lines in hrev35120. Also the spacing should be the same in both dialogs since I get it from be_control_look. Are you talking about a different dialog then the two above mentioned?

comment:5 Changed 9 years ago by humdinger

Strangeness. I see the changes in the "Create" dialog (+":", -box), but the "Initialize" dialog is unchanged. Still talking about the same dialogs...
I just freshly jam -qa to hrev35141.

in the Create-dialog should be "Active partition".?

comment:6 Changed 9 years ago by julun

Resolution: fixed
Status: reopenedclosed

Hi, all outstanding issues should be fixed in hrev35144.

comment:7 Changed 9 years ago by humdinger

Confirmed. Thanks!

Note: See TracTickets for help on using tickets.