Opened 10 years ago

Closed 15 months ago

Last modified 15 months ago

#4480 closed bug (fixed)

Screen gets black after bootscreen (GeForce 7600 Go)

Reported by: fleximus Owned by: rudolfc
Priority: normal Milestone: R1
Component: Drivers/Graphics/nVidia Version: R1/pre-alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I'm running Haiku hrev33041 on my Toshiba P100-102 and the screen gets now black after the bootscreen. Everything else works, I can even take screenshots. Running fail safe video mode works.

My GeForce was working for a very long time with a screen resolution of 1440x900x32. After rebuilding the system this is now new to me. Unfortunately I can't really say which revision I was before at.

Attachments (3)

syslog (79.3 KB ) - added by fleximus 10 years ago.
nvidia.10de_0398_010000.0.log (74.0 KB ) - added by fleximus 10 years ago.
nvidia-7600go_cocobean.png (131.2 KB ) - added by cocobean 15 months ago.
HP Laptop w/Nvidia GeForce 7600 Go

Download all attachments as: .zip

Change History (18)

by fleximus, 10 years ago

Attachment: syslog added

comment:1 by rudolfc, 10 years ago

Hi there,

Can you please install the nvidia.settings file in home/config/settings/kernel/drivers (if I'm right), and enable full logging in this file?

Please reboot with the driver, after completion grab the resulting nvidia.xxx.0.log (or something) file from your home folder and upload it here. (if you can blindly shutdown after the boot and then reboot into failsave video mode you'll find the logfile).

Thanks in advance!

Rudolf.

by fleximus, 10 years ago

comment:2 by rudolfc, 10 years ago

Hi,

The driver detects your screen allright. Could you remove the following files:

in home/config/settings/kernel/drivers, remove the vesa file; in home/config/settings/system/app_server, remove the settings file.

Please don't use the screen prefs panel: app_server will ask the driver for the panel's native mode and then set it upon the next boot.

Does this work?

Bye!

Rudolf.

in reply to:  2 comment:3 by fleximus, 10 years ago

Hi Rudolf,

I deleted the file home/config/settings/kernel/drivers/vesa and rebooted. The screen still appears black. There was no file home/config/settings/system/app_server/settings, only a file named workspaces which I did not delete. Should I have?

Looking forward for further instructions.

Felix

comment:4 by rudolfc, 10 years ago

yes, that folder should be empty. Could you upload a log from your next try?

Thanks!

BTW can you find out what the latest revision (or driver version) was that worked correctly for you? That would be a great help I expect!

comment:5 by fleximus, 10 years ago

I don't know the revision I had before it worked. Will I be able to see this in my checked out repsitory files? I updated the system to hrev33990 now, it is still black when starting the fresh system.

Now which files do you want me to upload syslog or a nvidia.xxx.0.log? For the later one I understand that there must be the nvidia.settings file in place with full logging. Do you wanted me to delete this file?

Thanks for clarification, little bit confused now :-)

comment:6 by rudolfc, 10 years ago

I'm interested in nvidia.xxx.0.log only so to speak :-) So, remove the vesa and app_server files, remove the old nvidia logfile, enable full logging in the nvidia settings file, and reboot. Grab the new nvidia log file and upload it here :)

Can you also do this test after that: try the setting: switchhead true in the nvidia.settings file to see if that gives you a picture. This will tell the driver to use the other head for outputting the picture. The largest thing that has changed in the driver over the past 6 months or so has to do with monitor detection and thus possibly routing over head1 or head2.

So: please have the switchhead option in place, remove the old nvidia.log file as well (and the vesa file and the app_server files) and then reboot.

Grab the newly created nvidia logfile as well and upload it here please :)

Bye!

Rudolf.

comment:7 by scottmc, 8 years ago

Blocking: 7665 added

comment:8 by waddlesplash, 2 years ago

Adding boot-failure keyword to all relevant still-open tickets.

comment:9 by waddlesplash, 2 years ago

Adding "boot-failure" keyword to all relevant tickets (try 2?)

comment:10 by waddlesplash, 2 years ago

Adding "boot-failure" keyword to all relevant tickets (try 3?!)

comment:11 by cocobean, 15 months ago

hrev52020 x86_64. I have a laptop with a GeForce Go 7600 in which Haiku currently works with it, so this may no longer be a issue?

comment:12 by rudolfc, 15 months ago

Cocobean, can you give me your PCI device cardID, and can you verify the driver is actually in use here? (for instance let the driver create the accelerant logfile) Please note that if you have another id, but 'coarse-like' the same card, it might still be the problem persists for specific users. This user has cardID 0x0398. Though I guess if a ticket has been silent for a very long time, one could argue to close it..

Last edited 15 months ago by rudolfc (previous) (diff)

by cocobean, 15 months ago

Attachment: nvidia-7600go_cocobean.png added

HP Laptop w/Nvidia GeForce 7600 Go

comment:13 by cocobean, 15 months ago

This is from an HP Pavilion laptop with a Nvidia GeForce 7600 Go tested with hrev51952 x86. Screen resolutions selectable are from 640x480x32 to 1440x900x32 for my laptop's monitor. Supports screen resolution up to 2048x1536 on an external monitor.

$listdev
device Display controller (VGA compatible controller, VGA controller) [3|0|0]
  vendor 10de: NVIDIA Corporation
  device 0398: G73M [GeForce Go 7600]

$ listimage|grep driver
1382 0x821b7000 0x821ba000     0          0 /boot/system/add-ons/kernel/drivers/dev/graphics/nvidia

Note the reporter's issue happened "after" updating to hrev33041 (but it worked beforehand).

Last edited 15 months ago by cocobean (previous) (diff)

comment:14 by rudolfc, 15 months ago

Resolution: fixed
Status: newclosed

Thanks. Your ID is the same, and so is your screen resolution. Assuming this problem is fixed indeed. Closing ticket.

comment:15 by waddlesplash, 15 months ago

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.