Opened 10 years ago

Closed 9 years ago

#4495 closed bug (fixed)

MDR Silently Fails if default folders do not exist

Reported by: Jason Owned by: nobody
Priority: low Milestone: R1/alpha2
Component: Servers/mail_daemon Version: R1/alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by phoudoin)

Reproduction:

  1. Installed Haiku Alpha 1.
  2. Setup MDR
  3. Symptoms:
    1. Default Mail folders (inbox and out) did not exist under ~/mail
    2. MDR would not send email without said folders
    3. MDR displayed error message for ~/mail/inbox not existing
    4. MDR did not display error message for ~/mail/out existing
    5. Mail would not send without ~/mail/out folder
    6. Outbox mail would be created in ~/

Workaround:

  • Create 'inbox' and 'out' in ~/mail if they are not created upon Alpha 1 install.

Expected MDR behavior:

  • create any missing folders that exist in its configuration if the folders do not in fact exist.
  • give an error message if the OUTBOX folder doesn't exist.
  • NEVER put mail files in OTHER folders if the folders in the configuration do not exist.

Change History (6)

comment:1 Changed 10 years ago by Jason

CORRECTION: ~/Mail should read ~/mail

comment:2 Changed 10 years ago by jackburton

Description: modified (diff)
Milestone: R1R1/alpha2

comment:3 Changed 10 years ago by phoudoin

Description: modified (diff)

comment:4 Changed 9 years ago by stippi

Owner: changed from bga to stippi
Status: newin-progress

comment:5 Changed 9 years ago by stippi

Owner: changed from stippi to nobody
Priority: normallow
Status: in-progressassigned

I can't confirm the behavior described in the original report. Draft mails seem to be stored always, there is code which checks specifically for the return code for a missing draft directory and creates the directory if missing. Perhaps this has been added after the ticket was created.

Creating the mail/out folder, or whatever other folder is configured for outgoing mail, was implemented as well. However, another bug apparently causes the configuration of the out folder not arriving at the place where sending the mail happens. I've added a fallback for this situation in hrev36490. Outgoing mails will now always be stored in ~/mail/out as a last resort.

Another curious thing is that stock Haiku images seem to already contain mail/in, mail/out and mail/drafts. I haven't found the place where these folders are created. On top of that, Mail calls it "draft", note the missing s. So after saving the first draft mail, the user will be left with mail/draft and an empty mail/drafts.

I may or may not find the time to look deeper into this, however, the problem is now much less severe.

comment:6 Changed 9 years ago by stippi

Resolution: fixed
Status: assignedclosed

The folders are created in HaikuImage, no clue why I didn't find the spot before. I've already renamed drafts to draft. Beam also calls it draft. Considering this ticket fixed.

Note: See TracTickets for help on using tickets.