Opened 10 years ago

Closed 8 years ago

#4499 closed bug (fixed)

Mouse get stuck in corner

Reported by: miffe Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/Development
Keywords: Cc: mdisreali@…
Blocked By: Blocking: #6490
Has a Patch: no Platform: x86

Description

When I have my usb gamepad connected, the mouse cursor get stuck in the lower right corner. When i try to move it, i can see it moving for short while, then it jumps back into the corner.

This happens with the touchpad, a wireless usb mouse and a logitech mx518 usb mouse. The gamepad is an Saitek P880. The computer is an Asus EEE 900.

Attaching the output of listdev, listusb and listusb -v.

Attachments (4)

dev.txt (2.7 KB) - added by miffe 10 years ago.
usb.txt (846 bytes) - added by miffe 10 years ago.
usb-v.txt (23.3 KB) - added by miffe 10 years ago.
listusb_acer_am5620_with_gamepad.txt (14.4 KB) - added by Disreali 8 years ago.

Download all attachments as: .zip

Change History (14)

Changed 10 years ago by miffe

Attachment: dev.txt added

Changed 10 years ago by miffe

Attachment: usb.txt added

Changed 10 years ago by miffe

Attachment: usb-v.txt added

comment:1 Changed 10 years ago by mmlr

Component: - GeneralDrivers/USB
Owner: changed from axeld to mmlr
Status: newassigned

That's a feature! You're supposed to move the cursor with the gamepad ;-) Kidding aside, this probably comes from a wrong conversion of incoming values in usb_hid. Or even more likely it is due to completely disregarding null states in usb_hid so far. Need to look into it.

comment:2 Changed 10 years ago by alex12

I have the same issue. I tried 2 separate ps/2 mice and a usb mouse.

comment:3 in reply to:  2 ; Changed 10 years ago by mmlr

Replying to alex12:

I have the same issue. I tried 2 separate ps/2 mice and a usb mouse.

You mean in combination with a USB gamepad, right? If the mice don't work themselves then that'd be another issue. Also if both PS/2 and USB are affected it'd likely be a problem in input_server. If it is in combination with another USB input device, does it behave normally if this extra device is removed?

comment:4 in reply to:  3 Changed 10 years ago by alex12

Replying to mmlr:

Replying to alex12:

I have the same issue. I tried 2 separate ps/2 mice and a usb mouse.

You mean in combination with a USB gamepad, right?

Yeah, only when my GameCube/Xbox/Playstation controller adapter is plugged in that it doesn't work. Without it both ps/2 and usb mice work.

comment:5 Changed 8 years ago by Disreali

Cc: mdisreali@… added
Version: R1/alpha1R1/Development

Also experiencing this issue on hrev40934-4h with a Logitech USB Cordless RumblePad 2. The mouse pointer jumps to the corner the instant I press any button, d-pad, or analog stick. I also noticed that gamepad_button_1 corresponds to the primary mouse button and gamepad_button_2 to the secondary mouse button.

Changed 8 years ago by Disreali

comment:6 Changed 8 years ago by modeenf

Blocking: 6490 added

comment:7 Changed 8 years ago by mmlr

Blocking: 6490 removed

comment:8 Changed 8 years ago by mmlr

Blocking: 6490 added

(In #6490) Replying to modeenf:

hm how does one close it as a duplicate?

By "resolve as" -> "duplicate". Maybe you don't have the right permissions to do so though. And you must not add blocking manually to the other ticket as otherwise it'll prevent this from being closed. It gets added automatically.

comment:9 Changed 8 years ago by mmlr

This is "expected" right now, as usb_hid doesn't, in the current form, enumerate devices by their application collections but by their report items. Gamepads and joysticks or anything with an X and Y axis are therefore interpreted as mice and can be used as such. This was originally by design to get things working. It'd not be a problem per se either, as when not using the devices it should simply not move the cursor. However, since the null states and units aren't implemented either, these devices will cause the described symptoms. I'm currently restructuring the usb_hid driver (see #7354) which will change the enumeration. After that proper support for these device types will be added (see #7429 and #7354 again).

comment:10 Changed 8 years ago by mmlr

Resolution: fixed
Status: in-progressclosed

Fixed in hrev41794. Joystick/gamepad support is further going to be tracked in #7429 and/or #7354.

Note: See TracTickets for help on using tickets.