Opened 9 years ago

Last modified 4 years ago

#4503 new bug

Bootman won't install on a mixed IDE and AHCI system

Reported by: ddewbofh Owned by: nobody
Priority: normal Milestone: R1
Component: Applications/BootManager Version: R1/alpha1
Keywords: Cc: pascal.penners@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I can install Haiku just fine from cd on this system but running bootman gives me a "Partition Table Not Compatible" error.

I've tried creating partitions both with DriveSetup as well as fdisk with the same result. I've run bootman both from the livecd as well as from the harddrive which I booted by using the cdrom bootloader.

The SATA controller is ICH9 and the IDE controller is a JMicron.

Attachments (1)

screenshot1.png (140.9 KB) - added by ddewbofh 9 years ago.
Screenshot of the bootman error

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by ddewbofh

Attachment: screenshot1.png added

Screenshot of the bootman error

comment:1 Changed 9 years ago by ddewbofh

Forgot to add that the cdrom is connected to the first IDE-channel as a master and the SATA-disk is connected to the first SATA-port.

comment:2 Changed 9 years ago by ddewbofh

Additional info:

After installing Haiku on three different machines I think I may have tracked down what might be the problem.

The drive-interfaces in DriveSetup are ordered alphabetically so IDE shows up before SCSI/SATA and USB. The other systems I successfully installed bootman on were booted from either USB or SATA without any IDE drives. The drive I installed from was listed below the target in DriveSetup.

Maybe bootman tries to install on the first disk in the list, regardless of whether it's writable or not?

comment:3 Changed 9 years ago by Cytor

Cc: pascal.penners@… added

Same problem for me. Two hard drives on ICH8-M AHCI, one optical drive on ICH8-M ATA. Also tried creating partitions with parted, but no success.

Workaround: temporarily setting the controller mode from AHCI to IDE (if you can); then BootMan is able to properly install. After that, reboot and set the mode back to AHCI. BootMan will work and boot the system just fine. This worked for me. So maybe this is just an issue with the BootMan installer and not with the actual bootloader itself?

comment:4 Changed 8 years ago by scottmc

Milestone: R1R1/beta1

comment:5 Changed 7 years ago by diver

Component: System/Boot LoaderApplications/BootManager
Owner: changed from axeld to nobody

comment:6 Changed 4 years ago by pulkomandy

Is this still reproducible? I don't have a mixed SATA/IDE machine to test...

comment:7 Changed 4 years ago by axeld

Milestone: R1/beta1R1

No need to delay beta1 because of this one.

Note: See TracTickets for help on using tickets.