Opened 10 years ago

Closed 9 years ago

#4541 closed bug (fixed)

New website doesn't load properly every so often: displaced elements

Reported by: PieterPanman Owned by: haiku-web
Priority: normal Milestone: R1
Component: Website/CMS Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

One in about 20 times I load the Haiku front page (new website), it places some items in the wrong location. See attached screenshot. In this case, it had remembered my login. This was about 8:50 amsterdam time. I haven't found a pattern yet.

Attachments (4)

Screenshot-Haiku Project | Home of the Haiku Operating System - Mozilla Firefox.png (172.2 KB) - added by PieterPanman 10 years ago.
BeZillaBrowser-noimages.png (132.4 KB) - added by idefix 10 years ago.
screenshot of BeZillaBrowser rendering haiku-os.org with images disabled
--www.haiku-os.org-.png (132.6 KB) - added by PieterPanman 10 years ago.
Screenshot-Element Properties.png (25.5 KB) - added by PieterPanman 10 years ago.

Download all attachments as: .zip

Change History (21)

comment:1 Changed 10 years ago by nielx

Are all elements present or are several images not loaded?

I have a feeling that every now and then the server is overloaded and does not send an image. If the layout depends on them, then this means that the layout is broken.

comment:2 Changed 10 years ago by leavengood

This was happening before more reproducibly (usually on first load, and then a reload would fix it) and Jorge did something to fix it (a few different times too since it reappeared.)

Niels might be on to something about the image loading. I guess we have to see what Jorge says he did to fix it before, that might give some indication of the cause.

comment:3 Changed 10 years ago by PieterPanman

Nope, as far as I can see on my screenshot all images are there. But next time I'll keep the page open, maybe I can provide some debugging information.

comment:4 in reply to:  2 Changed 10 years ago by idefix

Replying to leavengood:

Niels might be on to something about the image loading. I guess we have to see what Jorge says he did to fix it before, that might give some indication of the cause.

I would say it's definitely an image loading issue. If I disable images in Opera 10, the layout of the front page is the same as shown in the screenshot.

comment:5 Changed 10 years ago by PieterPanman

Hmm, disabling images on Fedora 11 and Firefox 3.5.3 doesn't show the same issue. Not sure what might be causing this.

comment:6 Changed 10 years ago by koki

I doubt it is a server related problem, as when this first manifested, it was running off my server under practically no load, and I was able to reproduce it 100% of the time.

Just to verify, are you seeing this (under normal configuration) in Firefox or in other browsers as well?

This used to happen in Firefox 3.5 on first load only, at two different stages in the development of the new website theme: the first time, I fixed it, but I did not make a note of how (was in a rush); the second time, the problem just went away, and I am now unable to reproduce it here.

I suspect a problem in the preface area of the front page (where the download box is), and I will try to look into it; but I need to setup a test environment (can't do this on the live site), so it may take a while.

comment:7 Changed 10 years ago by mmlr

I've seen this kind of problems when the image width/heights aren't specified on images. In some cases it would then mess up the layout when the images aren't available at the right time.

comment:8 in reply to:  5 Changed 10 years ago by idefix

Replying to PieterPanman:

Hmm, disabling images on Fedora 11 and Firefox 3.5.3 doesn't show the same issue. Not sure what might be causing this.

Strange, disabling images in BeZillaBrowser does show the same issue.

Changed 10 years ago by idefix

Attachment: BeZillaBrowser-noimages.png added

screenshot of BeZillaBrowser rendering haiku-os.org with images disabled

comment:9 Changed 10 years ago by PieterPanman

I got it again, without disabling images. http://test.haikuzone.net/files/imagepicker/5/thumbs/r1a1cd.png didn't load, and it doesn't have size tags. See attached screenshot of what firefox 3.5 thinks of it. Probably fixing the image sizes (and moving it to the real server?) will fix it.

Changed 10 years ago by PieterPanman

Attachment: --www.haiku-os.org-.png added

Changed 10 years ago by PieterPanman

comment:10 in reply to:  9 Changed 10 years ago by koki

Replying to PieterPanman:

I got it again, without disabling images. http://test.haikuzone.net/files/imagepicker/5/thumbs/r1a1cd.png didn't load, and it doesn't have size tags. See attached screenshot of what firefox 3.5 thinks of it. Probably fixing the image sizes (and moving it to the real server?) will fix it.

This is a different/unrelated problem, which I just fixed.

comment:11 in reply to:  7 Changed 10 years ago by koki

Replying to mmlr:

I've seen this kind of problems when the image width/heights aren't specified on images. In some cases it would then mess up the layout when the images aren't available at the right time.

I followed your lead and added width/height to the navigation icons (top right corner).

Can you please see if you are still able to reproduce this problem?

comment:12 Changed 10 years ago by idefix

The layout now stays the same when I disable images in Opera 10, so I think this problem is fixed.

comment:13 Changed 10 years ago by koki

Has anyone seen this problem happen again? If not, we could close this bug report.

comment:14 Changed 10 years ago by luroh

Yes, if I go to http://www.haiku-os.org/community and hit Ctrl-F5, the navigation menu is stuck centered on the screen until a reload. Funnily though, doing the same on http://www.haiku-os.org/development works fine - the navigator menu appears in the middle but pops into place quickly.

comment:15 Changed 10 years ago by PieterPanman

I have not seen the original problem anymore, but I do see the problem Luroh reported above. (exactly as he describes it)

comment:16 Changed 9 years ago by PieterPanman

Can this be closed? Don't remember seeing any of these issues in the last months.

comment:17 Changed 9 years ago by stippi

Resolution: fixed
Status: newclosed

Yeah, I seem to remember discussion, fixes and then consense that this bug was fixed. :-)

Note: See TracTickets for help on using tickets.