Opened 10 years ago

Closed 7 years ago

Last modified 14 months ago

#4561 closed bug (duplicate)

Can't get Haiku to boot in Parallels

Reported by: dfurrer Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers/Disk Version: R1/Development
Keywords: Haiku Parallels Boot Cc:
Blocked By: #4502 Blocking:
Has a Patch: no Platform: x86

Description

I'm using Parallels 4.0.3522 and mounting the iso image to start from.

Haiku gets stuck during startup.

The last line of output I get in verbose mode is the following:

"ata 0 error: device still expects data transfer"

I'm attaching screen captures with more information.

Note: I tried running file-safe and file-safe with disabled IDE DMA. No difference.

Attachments (2)

haiku1.tiff (74.6 KB ) - added by dfurrer 10 years ago.
haiku2.tiff (64.8 KB ) - added by dfurrer 10 years ago.

Download all attachments as: .zip

Change History (16)

by dfurrer, 10 years ago

Attachment: haiku1.tiff added

by dfurrer, 10 years ago

Attachment: haiku2.tiff added

comment:1 by jackburton, 10 years ago

Can you enable boot screen debug ?

comment:2 by jackburton, 10 years ago

Sorry I see you already did.

comment:3 by axeld, 10 years ago

Component: Kits/Kernel KitSystem
Owner: changed from axeld to nobody

comment:4 by stefan_s, 9 years ago

Keywords: Haiku Parallels Boot added

If the virtual hard disk file is resized to 1 GB (from the initial 0.6 GB with the "Parallels Image Tool") then Haiku boots without problems.

I think it has nothing to do with the ATA/IDE drivers, it looks like this issue comes from how Haiku is handling partitions on the disk, as it doesn't boot from SCSI nor IDE virtual disks unless the disk image is resized. After resizing, it boots from IDE (but not from SCSI) without any problems (apart from being extremely slow).

in reply to:  4 comment:5 by bonefish, 9 years ago

Replying to stefan_s:

If the virtual hard disk file is resized to 1 GB (from the initial 0.6 GB with the "Parallels Image Tool") then Haiku boots without problems.

I think it has nothing to do with the ATA/IDE drivers, it looks like this issue comes from how Haiku is handling partitions on the disk, as it doesn't boot from SCSI nor IDE virtual disks unless the disk image is resized. After resizing, it boots from IDE (but not from SCSI) without any problems (apart from being extremely slow).

Haiku doesn't support SCSI devices, so not being able to boot from those is quite expected. That aside, an update how it works with a recent Haiku version would be appreciated. Ideally including a syslog.

comment:6 by RichardG, 9 years ago

I can verify that Alpha 2 does not boot on Parallels 6.0.11994 with the default configuration. I'll try to post more information on it later.

comment:7 by scottmc, 8 years ago

Can you recheck this with a recent Haiku build?

comment:8 by scottmc, 8 years ago

Blocking: 7665 added

comment:9 by RangerRick, 8 years ago

I can confirm this same behavior with Parallels 6 (6.0.12094) and the latest Haiku nightly:

Information about this build:

Haiku repository: hrev42637 <http://svn.haiku-os.org/haiku/haiku/trunk> Buildtools repository: hrev42621 <http://svn.haiku-os.org/haiku/buildtools/trunk> Configure command: ../haiku/configure --use-gcc-pipe --use-xattr --cross-tools-prefix /Build-O-Matic/output/generated.x86gcc2/cross-tools/bin/i586-pc-haiku- --alternative-gcc-output-dir /Build-O-Matic/output/generated.x86gcc4 Jam command: jam -q -j1 -sHAIKU_IGNORE_USER_BUILD_CONFIG=1 -sHAIKU_DISTRO_COMPATIBILITY=official @nightly-anyboot Host machine: FreeBSD 8.2-RELEASE 32bit i386

This is my first attempt installing Haiku. I grabbed the anyboot image, as well as gparted. Created a 20GB VM drive, booted gparted and created an MSDOS partition map with a single HFS+ partition in it (since there was no BFS choice in the GParted live CD, hoped I could replace it during install).

I booted with debug console and received the same "ata 0 error: device still expects data transfer" as the last update.

Anything else I can do to help debug it?

comment:10 by RangerRick, 8 years ago

Also, I tried changing the hard drive to be SCSI instead of ATA, same issue. (CDROM was still ATA, since it wouldn't treat it as a boot disk otherwise...)

comment:11 by diver, 8 years ago

Probably the same problem as in #4502.

comment:12 by diver, 7 years ago

Blocked By: 4502 added
Component: SystemDrivers/Disk
Resolution: duplicate
Status: newclosed
Version: R1/alpha1R1/Development

comment:13 by mmika, 6 years ago

Hello all! So what does community think about reason for this message? The situation is not clear for me. The last command processed by DVD drive was: 0x28 0x00 0x00 0x00 0x00 0x00 0x00 0x01 0x00 0x00 0x00 0x00 i.e read10 of 256 sectors from LBA=0 This request looks strange for CD media and it's size also a bit confusing. Anyway all transfer stalls after interrupt generation on transfer complete. A kernel code loops reading Interrupt reason register and Byte count low register (aka 0x1f2 and 0x1f4). The requested transfer mode was PIO. There was no PIO data read after interrupt on transfer generated.

So I look into the code ATAChannel::ExecutePIOTransfer and can assume that "while (*bytesLeft > 0)" loop was not entered.

Obviously that device is ready to transfer 0x80000 bytes via PIO, so Status register has DRDY, DSC and DRQ bits set.

comment:14 by waddlesplash, 14 months ago

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.