Opened 10 years ago

Closed 8 years ago

Last modified 15 months ago

#4583 closed bug (fixed)

"PANIC did not find any boot partitions" message with SIS IDE controller

Reported by: peapa Owned by: marcusoverhagen
Priority: normal Milestone: R1
Component: Drivers/Disk Version: R1/alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

When attempting to start Haiku Alpha 1 on my computer from a cdrom I got this error message just after the splash screen appeared. I already tried to disable DMA in the safe mode otions but it did not help.

My motherboard is an MS-6533 with a SIS 5513 IDE controller.

Attachments (2)

haiku_p4_Intel850_noboot.txt (50.7 KB ) - added by andzs 10 years ago.
haiku-alpha-1-no-boot-partitions.jpg (22.9 KB ) - added by sikosis 10 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 by peapa, 10 years ago

Summary: "PANIC did not find any boot partitions message" with SIS IDE controller"PANIC did not find any boot partitions" message with SIS IDE controller

comment:2 by andzs, 10 years ago

The same problem on P4 system with Intel 850 chipset where original Beos boots fine. I'll add serial debugging output.

by andzs, 10 years ago

comment:3 by sikosis, 10 years ago

I have the same issue on a Dell Optiplex 960 and my MSI Wind U100. Strangely, I've been able to get the alpha to boot into the live mode prior and the same CD now won't.

comment:4 by Disreali, 10 years ago

Is this a duplicate of ticket #4058 ?

in reply to:  4 comment:5 by andzs, 10 years ago

Replying to Disreali:

Is this a duplicate of ticket #4058 ?

Could be. But #4058 emphasizes switching to new ATA stack in development versions, but this one is related to Alpha release.

comment:6 by tonestone57, 9 years ago

I noticed in syslog:
ata 0 error: command failed, error bit is set. status 0x51, error 0x04

Did a little searching on it. Usually one of 3 things 1) failing drive (sector not found) - should test with manufacturer diagnostics software (quick+full) 2) BIOS settings 3) buggy driver.

You can try playing with BIOS settings, enable SMART, disable DMA, setting UDMA mode 2 (rather than auto), checking over your primary and secondary drive info to match installed hardware, (looking over drive connections can't hurt either), etc.

A little extra information about this error on Linux:
http://www.captain.at/howto-linux-driveready-seekcomplete-error-drivestatuserror.php

comment:7 by scottmc, 8 years ago

Can you recheck this with a recent Haiku build? It may have been fixed recently.

comment:8 by scottmc, 8 years ago

Blocking: 7665 added

comment:9 by peapa, 8 years ago

I just tried with Haiku hrev42190 and everything works perfectly

The cdrom loaded without problems, I installed Haiku and was able to start it. I think this bug is fixed.

comment:10 by anevilyak, 8 years ago

Resolution: fixed
Status: newclosed

Thanks for the update!

comment:11 by waddlesplash, 15 months ago

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.