Opened 10 years ago

Last modified 8 years ago

#4624 new bug

Audio garbled with OSS on CS4624/CS4297A audio chipset

Reported by: thetick Owned by: mmu_man
Priority: normal Milestone: R1
Component: Drivers/Audio/OpenSound Version: R1/alpha1
Keywords: Cc: bergep@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I have CS4624/CS4297A AC'97 Audio controller supported by OSS on Linux. See http://www.thinkwiki.org/wiki/CS4624 and http://www.thinkwiki.org/wiki/CS4297

I'm using the Haiku R1 Alpha with the oss in the optional downloads. I also removed the other audio drivers. Not sure but should the HDA driver work since it's an AC97 chipset and uses the snd-intel8x0 kernel module with Linux.

Attached is ossinfo text and the syslog.

Attachments (2)

ossinfo.txt (554 bytes) - added by thetick 10 years ago.
Data from ossinfo
oss_syslog_listdev.txt (661 bytes) - added by thetick 10 years ago.
oss in syslog and the device listing from listdev

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by thetick

Attachment: ossinfo.txt added

Data from ossinfo

Changed 10 years ago by thetick

Attachment: oss_syslog_listdev.txt added

oss in syslog and the device listing from listdev

comment:1 Changed 10 years ago by thetick

Cc: bergep@… added

comment:2 Changed 10 years ago by rudolfc

Hi,

Please make sure that you have _disabled_ serial debugging as that compromizes timing!

Bye!

Rudolf.

comment:3 Changed 9 years ago by thetick

Success ... with hrev34909 , open sound and all the other audio drivers removed (ie hda, emu.. ect) my audio is working great. Now here is the real odd part if I reset the media services then the audio is dead and driver is no longer showing. I reboot and the audio is still not found. Its only when I boot linux , run "play <any wav file>.wav" then shutdown then boot haiku my audio is working fine! Also I must use the linux dsp audio driver (ie play a .wav) for this to work. Just rebooting linux and shutting down does not allow the audio to work on the next Haiku boot.

So I am just guessing but it seems like the audio chipset must be in a certain hardware state to function correctly with the Haiku OSS and playing a Linux wav file sets up audio hardware such that a reboot then allows the Haiku OSS driver to work. Note I suspect the battery could still perseve the hardware state of the audio hardware.

Also to back up my theroy if I remove all power including the battery, the Haiku audio is broken regardless of the procedure above.

I've tried this nummerous times and can consistantly with the rules above break or enable the audio with Haiku.

Anyone care to comment? I would like to have audio working without the above Linux intervention.

comment:4 Changed 8 years ago by diver

Component: Drivers/AudioDrivers/Audio/OpenSound
Owner: changed from korli to mmu_man
Note: See TracTickets for help on using tickets.