Opened 10 years ago

Last modified 10 months ago

#4635 reopened bug

Audio not working with Dell Latitude D820 HD audio device

Reported by: Cypress Owned by: korli
Priority: normal Milestone: R1/beta2
Component: Drivers/Audio/HDA Version: R1/alpha2
Keywords: Cc:
Blocked By: Blocking: #7722
Has a Patch: no Platform: x86

Description

I have a Dell Latitude D820 laptop and Haiku runs just fine on in, apart from the audio. The HDA is detected and I can change volume, but there's no sound coming from applications. The sound card is a Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller. MediaPlayer plays movies, sould applications play the wav files I give them to play, but there's no sound. I tried restarting MediaServer many times but the result is the same. I tried several drivers including the AC'97 one on bebits/haikufiles but it doesn't work. No sound at all.

Attachments (1)

syslog.gcc2hybrid.r40056.txt (83.7 KB ) - added by gallimaufry 9 years ago.
Dell Latitude D820 shortly after boot.

Download all attachments as: .zip

Change History (19)

comment:1 by Cypress, 10 years ago

Further information:

~> listdev | grep Audio

  device Multimedia controller (Audio device) [4|3|0]
  device 27d8: 82801G (ICH7 Family) High Definition Audio Controller

~> listimage | grep drivers/

   50                  /boot/system/add-ons/kernel/drivers/dev/console 0x80581000 0x80583000    0          0
   51                  /boot/system/add-ons/kernel/drivers/dev/dprintf 0x80584000 0x80585000    0          0
   52                 /boot/system/add-ons/kernel/drivers/dev/keyboard 0x80586000 0x80588000    0          0
   53                     /boot/system/add-ons/kernel/drivers/dev/null 0x80589000 0x8058a000    0          0
   54                   /boot/system/add-ons/kernel/drivers/dev/random 0x8058b000 0x8058e000    0          0
   55                      /boot/system/add-ons/kernel/drivers/dev/tty 0x8058f000 0x80598000    0          0
   56                     /boot/system/add-ons/kernel/drivers/dev/zero 0x8059c000 0x8059d000    0          0
  358         /boot/system/add-ons/kernel/drivers/dev/net/broadcom570x 0x80d1f000 0x80d38000    0          0
  377          /boot/system/add-ons/kernel/drivers/dev/graphics/nvidia 0x80601000 0x80604000    0          0
  381            /boot/system/add-ons/kernel/drivers/dev/graphics/vesa 0x8063e000 0x80641000    0          0
  553            /boot/system/add-ons/kernel/drivers/dev/input/usb_hid 0x83e55000 0x83e5d000    0          0
  555              /boot/system/add-ons/kernel/drivers/dev/input/wacom 0x83e5e000 0x83e60000    0          0
  564         /boot/system/add-ons/kernel/drivers/dev/audio/hmulti/hda 0x83e61000 0x83e6a000    0          0
  595              /boot/system/add-ons/kernel/drivers/dev/bus/usb_raw 0x83ed4000 0x83ed6000    0          0
TEAM  282 (/bin/grep drivers/):
~> 
Last edited 8 years ago by diver (previous) (diff)

comment:2 by axeld, 10 years ago

Component: Audio & VideoDrivers/Audio/HDA
Owner: changed from nobody to korli

comment:3 by aljen, 10 years ago

it's a duplicate, see ticket 4492

comment:4 by Cypress, 10 years ago

It's not a duplicate of 4492. I plugged in headphones in the audio jack and still can't hear a sound.

comment:5 by michaelvoliveira, 10 years ago

same here:

~> listdev | grep Audio

  device Multimedia controller (Audio device) [4|3|0]
  device 03f0: MCP61 High Definition Audio

~> listimage | grep drivers/

   51                  /boot/system/add-ons/kernel/drivers/dev/console 0x8058c000 0x8058e000    0          0
   52                  /boot/system/add-ons/kernel/drivers/dev/dprintf 0x8058f000 0x80590000    0          0
   53                 /boot/system/add-ons/kernel/drivers/dev/keyboard 0x80591000 0x80593000    0          0
   54                     /boot/system/add-ons/kernel/drivers/dev/null 0x80594000 0x80595000    0          0
   55                   /boot/system/add-ons/kernel/drivers/dev/random 0x80596000 0x80599000    0          0
   56                      /boot/system/add-ons/kernel/drivers/dev/tty 0x8059a000 0x805a2000    0          0
   57                     /boot/system/add-ons/kernel/drivers/dev/zero 0x805a6000 0x805a7000    0          0
   58          /boot/home/config/add-ons/kernel/drivers/dev/oss_loader 0x805a8000 0x805a9000    0          0
  366          /boot/system/add-ons/kernel/drivers/dev/graphics/nvidia 0x805bd000 0x805c0000    0          0
  370            /boot/system/add-ons/kernel/drivers/dev/graphics/vesa 0x8060f000 0x80612000    0          0
  399               /boot/system/add-ons/kernel/drivers/dev/net/nforce 0x80d62000 0x80d78000    0          0
  465            /boot/system/add-ons/kernel/drivers/dev/input/usb_hid 0x841a6000 0x841af000    0          0
  466              /boot/system/add-ons/kernel/drivers/dev/input/wacom 0x80dfd000 0x80dff000    0          0
  623              /boot/system/add-ons/kernel/drivers/dev/bus/usb_raw 0x85c37000 0x85c39000    0          0

PS: I deleted hdmultiaudio because oss drivers conflict

Last edited 8 years ago by diver (previous) (diff)

comment:6 by michaelvoliveira, 10 years ago

Hi Korli!

seems that in the recent builds the hda drivers is working Ok, with only a little delay at startup (so, no startup sounds). No hickups are founded. ALL IS PERFECT!

So please close this bug after Cypress confirmation

THANKS FOR ALL HARD WORK!!!

comment:7 by axeld, 10 years ago

Resolution: fixed
Status: newclosed

But you are sure you have configured a startup sound? Because by default, Haiku is completely silent.

comment:8 by michaelvoliveira, 10 years ago

yes! for example. Haiku starts. the first thing that I do is open a mp3 file. When mediaplayer is playing + or - 15 sec, the sound finally cames out from my speakers.

Thanks anyway. Is fully usable for me now.

in reply to:  8 comment:9 by mmlr, 10 years ago

Replying to michaelvoliveira:

yes! for example. Haiku starts. the first thing that I do is open a mp3 file. When mediaplayer is playing + or - 15 sec, the sound finally cames out from my speakers.

That sounds a lot like you're still using OSS. I've noticed that hda + OSS doesn't conflict quite as badly as it used to, but you definitely don't want to use both at the same time.

comment:10 by michaelvoliveira, 10 years ago

absolutely not.. It's a clean gcc4hybrid build without any optional packages (except by development ones)

comment:11 by Cypress, 9 years ago

Resolution: fixed
Status: closedreopened

Cypress here. I'm using the new R1 alpha 2 build and the problem persists. No sound at all.

comment:12 by luroh, 9 years ago

Version: R1/alpha1R1/alpha2

Cypress: ticket #4755 suggests that OpenSound might work. Try to move /boot/system/add-ons/kernel/drivers/dev/audio/hmulti/hda out of the way and issue: installoptionalpackage -a opensound

comment:13 by Cypress, 9 years ago

Thank you. It's working now.

comment:14 by korli, 9 years ago

Summary: Audio not working with Intel Corporation 82801G (ICH7 Family) High Definition Audio ControllerAudio not working with Dell Latitude D820 HD audio device

It would be nice to provide a simple syslog.

comment:15 by luroh, 9 years ago

Cypress: any chance you could provide a syslog from a recent nightly, using the native HDA driver?

by gallimaufry, 9 years ago

Dell Latitude D820 shortly after boot.

comment:16 by gallimaufry, 9 years ago

I have a D820. So, I installed an alpha gcc2hybrid build at hrev40056. It exhibits the symptoms provided in the description. In addition to the syslog attached above...

Command

~> listdev | grep Audio

Output

device Multimedia controller (Audio device) [4|3|0]
  device 27d8: N10/ICH 7 Family High Definition Audio Controller

Command

~> listimage | sed -e '/drivers/!d' -e 's/^[ \t]*//g' -e 's/[ \t][ \t]*/ /g'

Output

50 /boot/system/add-ons/kernel/drivers/dev/console 0x81589000 0x8158b000 0 0
51 /boot/system/add-ons/kernel/drivers/dev/dprintf 0x81465000 0x81466000 0 0
52 /boot/system/add-ons/kernel/drivers/dev/null 0x81429000 0x8142a000 0 0
53 /boot/system/add-ons/kernel/drivers/dev/random 0x813d0000 0x813d3000 0 0
54 /boot/system/add-ons/kernel/drivers/dev/tty 0x8146b000 0x81474000 0 0
55 /boot/system/add-ons/kernel/drivers/dev/zero 0x813d4000 0x813d5000 0 0
436 /boot/system/add-ons/kernel/drivers/power/acpi_battery 0x81077000 0x81079000 0 0
645 /boot/system/add-ons/kernel/drivers/dev/graphics/nvidia 0x8104f000 0x81052000 0 0
650 /boot/system/add-ons/kernel/drivers/dev/net/broadcom43xx 0x8107a000 0x810de000 0 0
653 /boot/system/add-ons/kernel/drivers/dev/graphics/vesa 0x810eb000 0x810ee000 0 0
654 /boot/system/add-ons/kernel/drivers/dev/net/broadcom570x 0x81c84000 0x81ca0000 0 0
866 /boot/system/add-ons/kernel/drivers/dev/input/wacom 0x8135d000 0x8135f000 0 0
958 /boot/system/add-ons/kernel/drivers/dev/bus/fw_raw 0x8076c000 0x8076f000 0 0
960 /boot/system/add-ons/kernel/drivers/dev/bus/usb_raw 0x807d4000 0x807d6000 0 0
972 /boot/system/add-ons/kernel/drivers/dev/audio/hmulti/hda 0x807df000 0x807e9000 0 0

comment:17 by luroh, 8 years ago

Blocking: 7722 added

(In #7722) By the looks of it, you seem to have both OSS and HDA loaded, which is potentially bad since the drivers can conflict with each other. Please only use one at a time and attach the respective syslogs to #4635 like korli requested.

comment:18 by pulkomandy, 10 months ago

Milestone: R1R1/beta2
Note: See TracTickets for help on using tickets.