Opened 10 years ago

Closed 7 months ago

#4638 closed bug (fixed)

Kernel tries to load a directory as a driver

Reported by: colin Owned by: waddlesplash
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

When creating a new directory (e.g.: net) in /boot/home/config/add-ons/kernel/drivers/dev/ following message appears in the syslog:

KERN: Could not load kernel add-on "/boot/home/config/add-ons/kernel/drivers/dev/net": Is a directory

This is a reproducable bug, at least in R1/alpha1 (hrev33109).

The message in the syslog seems to be the only side effect of this bug.

I would expect the kernel not trying to load a directory as a driver at all. Thus no message that made me think, something went wrong with the driver installation.

Change History (3)

comment:1 Changed 2 years ago by axeld

Owner: changed from axeld to nobody
Status: newassigned

comment:2 Changed 21 months ago by waddlesplash

Owner: changed from nobody to waddlesplash

Reassign to myself. Saw this one earlier today, I might be able to tackle it...

comment:3 Changed 7 months ago by waddlesplash

Resolution: fixed
Status: assignedclosed

Fixed in hrev52760.

Note: See TracTickets for help on using tickets.