Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4646 closed enhancement (fixed)

OptionalPackages should store data in B_USER_SETTINGS_DIRECTORY instead of $HOME

Reported by: augiedoggie Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

It seems as though some packages like BeZilla and subversion have been patched to use B_USER_SETTINGS_DIRECTORY to store their configuration. Other packages like cvs, less, bash, vim, and others are still using $HOME to store things. It would be nice to clean these up and have it consistent.

Change History (5)

comment:1 by augiedoggie, 10 years ago

In addition:

Maybe an environment variable should be created so that applications that don't have access to the BeAPI could use the directory. I'm thinking of things like mercurial and other scripted applications.

Perhaps in the UserBootscript a command like:

export USER_SETTINGS_DIRECTORY=`/bin/finddir B_USER_SETTINGS_DIR`

comment:2 by augiedoggie, 10 years ago

Typo in the example, it should be:

export USER_SETTINGS_DIRECTORY=`/bin/finddir B_USER_SETTINGS_DIRECTORY`

comment:3 by siarzhuk, 10 years ago

Corresponding enhancement for my VIM package mirrored in Haiku-Ports Trac http://ports.haiku-files.org/ticket/222 Thank you for a note.

comment:4 by mmadia, 10 years ago

Resolution: fixed
Status: newclosed

Seeing as this is an issue with 3rd party software for Haiku, I'm closing this ticket. To note, there is a FindDirectory page at HaikuPorts that describes various ways to implement this.

in reply to:  4 comment:5 by augiedoggie, 10 years ago

Replying to mmadia:

Seeing as this is an issue with 3rd party software for Haiku, I'm closing this ticket. To note, there is a FindDirectory page at HaikuPorts that describes various ways to implement this.

I don't mind that you closed the ticket. If I wasn't so lazy I would have filed individual tickets. I would disagree with your reasoning though. 3rd party software is still included in the Haiku repository and has not been updated to use the proper directory. Until all of this software is moved to HaikuPorts then I think the problem is still valid.

Note: See TracTickets for help on using tickets.