Opened 10 years ago

Closed 10 years ago

#4667 closed bug (invalid)

Haiku creates bad zip files

Reported by: sikosis Owned by: nobody
Priority: normal Milestone: R1
Component: - General Version: R1/alpha1
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Tried zipping up some files under Haiku, copied them to a USB key and then tried to open that zip file on a Windows XP system and got the following error "The archive is either in unknown format or damaged" and therefore can't be opened.

Maybe copying the zip to the USB damaged it ?

Change History (5)

comment:1 by anevilyak, 10 years ago

Seems likely, at least the zips appear correct here (and work when scp'd across to another box). Can they be unzipped on Haiku itself before transferring? Can you compare md5s on the hard disk versus on the key?

comment:2 by siarzhuk, 10 years ago

Looks like zip-file data was partially transferred. I observe normally about 5-10 minutes of the "LED activity" after copying big files onto USB "flash" drive. Just run sync command in the Terminal to see when really all data completely transferred. :-(

comment:3 by sikosis, 10 years ago

I'll try those other things ... I also tried FTPing the file and it was corrupt at the other end.

comment:4 by sikosis, 10 years ago

ZIP file opens in Expander with no worries.

Haiku File MD5 -> 1e0961b4dc87c6395c2332a2c74d83e7

After FTP MD5 -> ccde8ee7f1e68d3df79cbb7802b8fb4f

comment:5 by sikosis, 10 years ago

Resolution: invalid
Status: newclosed

Formatted the USB key (standard not quick) and also dropped to Terminal and ran the "sync" command. File opens just fine now in Windows. Closing this ticket -- nothing to see, move along.

Note: See TracTickets for help on using tickets.