Opened 13 years ago

Closed 11 years ago

#471 closed bug (fixed)

[Deskbar] team item is drawn wrong

Reported by: diver Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Deskbar Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by wkornewald)

If you crash tracker (for example: #353) and then start tracker by pressing leaf button and then clicking on a folder (preferences/applicatons) you will see that tracker menu is drawn wrong in deskbar's team menu. Screenshot will follow.

Attachments (2)

deskbar.PNG (1.8 KB) - added by diver 13 years ago.
deskbar bug
deskbar_bug.PNG (3.7 KB) - added by jackburton 13 years ago.
deskbar bug

Download all attachments as: .zip

Change History (18)

comment:1 Changed 13 years ago by diver

attachments.mimetype: image/pngimage/bmp

comment:2 Changed 13 years ago by diver

attachments.isobsolete: 01

comment:3 Changed 13 years ago by diver

(From update of attachment 185) This is right shot, ignore above one.

Changed 13 years ago by diver

Attachment: deskbar.PNG added

deskbar bug

comment:4 Changed 13 years ago by korli

bug_group: developers

comment:5 Changed 13 years ago by jackburton

Is this problem still reproducible ? If not, I'll close it.

comment:6 Changed 13 years ago by diver

Yes(In reply to comment #4)

Is this problem still reproducible ? If not, I'll close it.

It still 100% reproducible, just to crash tracker you should see #708 instead ;-)

comment:7 Changed 13 years ago by jackburton

Seems to happen only if there are no items in deskbar (so that Tracker gets added as the first item)

comment:8 Changed 13 years ago by jackburton

More interesting: if you open other apps, the menu items gets larger (see attached screenshot)

comment:9 Changed 13 years ago by jackburton

Looks like the items width is always equal to the total height. Weird.

comment:10 Changed 13 years ago by jackburton

Moreover, it's reproducible also without crashing the tracker. I just kill it usin g the team monitor.

Changed 13 years ago by jackburton

Attachment: deskbar_bug.PNG added

deskbar bug

comment:11 Changed 13 years ago by wkornewald

Description: modified (diff)
Platform: All

comment:12 Changed 13 years ago by jackburton

Resolution: fixed
Status: newclosed

Does it happen under BeOS too, or only under Haiku ?

comment:13 Changed 13 years ago by jackburton

Resolution: fixed
Status: closedreopened

comment:14 Changed 13 years ago by diver

Yes, this happens under R5 too.

comment:15 Changed 12 years ago by jackburton

Component: - Applications- Applications/Deskbar

comment:16 in reply to:  15 Changed 11 years ago by aldeck

Resolution: fixed
Status: reopenedclosed

fixed in hrev25826

Note: See TracTickets for help on using tickets.